Media Player1.0 pre3 creating hell for me.help me out plz.

General discussion about Linux, Linux distribution, using Linux etc.

Media Player1.0 pre3 creating hell for me.help me out plz.

Postby zeeshan Hussain » Fri Dec 26, 2003 6:33 am

dear PlUC ians,
i downloaded a latest version of MPlayer from www.mplayerhq.hu and its a tar file,opened it up and when i tried to configure it,it said gcc 2.96 isnt supported and will never be. u must degrade/upgrade.

so i had to download the new C compiler, so i did gcc c++ 3.4. when i tried to run it,it stopped with an error saying, it needs gcc first and other C libraries. so i searched them out and successfully installed gcc 3.3.2

now i tried to configure the MPlayer and it worked.

the next step was to MAKE and it was HELL
it took so long and ended up with this

cc -c -O4 -march=pentium3 -mcpu=pentium3 -pipe -ffast-math -fomit-frame-pointer
-D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I. -Inative -I.. -I../libmpdemux -I../loader -D_GNU_SOURCE -I../libmpflac -o vd_lcl.o vd_lcl.c
vd_lcl.c: In function `init':
vd_lcl.c:222: error: `Z_NO_COMPRESSION' undeclared (first use in this function)
vd_lcl.c:222: error: (Each undeclared identifier is reported only once
vd_lcl.c:222: error: for each function it appears in.)
vd_lcl.c:222: error: `Z_BEST_COMPRESSION' undeclared (first use in this function)
make[1]: *** [vd_lcl.o] Error 1
make[1]: Leaving directory `/root/MPlayer-1.0pre3/libmpcodecs'
make: *** [libmpcodecs/libmpcodecs.a] Error 2

I can see so many Genees in this forum, may be u ppl can help me getting out of this .
Awaiting for ur helping replies.
zeeshan Hussain
Lance Naik
 
Posts: 28
Joined: Tue Sep 02, 2003 1:16 am
WLM: zeeshanhussain@pakistanmail.com
Yahoo Messenger: zeesh_tas@yahoo.co.in
Location: Karachi

Re:

Postby LinuxFreaK » Fri Dec 26, 2003 7:12 am

Dear Zeeshan Hussain,
Salam,

Sir, Please check out the blow links hope it will help you and solve you problem :)
http://www.mplayerhq.hu/DOCS/HTML/en/bu ... onpilation
http://www.mplayerhq.hu/DOCS/HTML/en/install.html

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Postby Faraz.Fazil » Mon Dec 29, 2003 8:51 pm

First of all, which distro are u using?

If you are using RedHat or Mandrake, i recommend you install the binary rpm packages (available at mplayerhq.hu)

Install them using rpm -Uvh rpmname.rpm command.

Which distribution are you using? Post the exact version.
One more thing...download and install the stable 0.9x version...and not the prerelease version 1.
Linux for Life!
Faraz.Fazil
Major General
 
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
WLM: faraz7476@hotmail.com
Location: Karachi/Pakistan/Earth/Universe


Return to “%s” General

Who is online

Users browsing this forum: No registered users and 1 guest

cron