Installation Problem

General discussion about Linux, Linux distribution, using Linux etc.
Zaheer
Battalion Havaldaar Major
Posts: 284
Joined: Fri Oct 17, 2003 12:15 am
Location: Karachi
Contact:

Installation Problem

Postby Zaheer » Tue Nov 11, 2003 4:22 pm

AOA,
I have problem with Installation of Packages.(RPM's).Whenever I try to Install any rpm I get msg's like these.


gtk+2.0 >= 2.0.0 is needed by gaim-0.72-1mdk9.1
libnss3 is needed by gaim-0.72-1mdk9.1
libaspell.so.15 is needed by gaim-0.72-1mdk9.1
libgtkspell.so.0 is needed by gaim-0.72-1mdk9.1
libpspell.so.15 is needed by gaim-0.72-1mdk9.1
libtcl8.3.so is needed by gaim-0.72-1mdk9.1
libtk8.3.so is needed by gaim-0.72-1mdk9.1
perl-base >= 2:5.8.0 is needed by gaim-0.72-1mdk9.1

Plz suggets me what is the problem and how I can get these files.
Regards
Good Judgement comes from Experience and Experience comes from bad Judgement!!
The more I know, the more I realize I don't know!?
The easiest way to find out is to try Out!!!

Registered Linux user #333501

Faraz.Fazil
Major General
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
Location: Karachi/Pakistan/Earth/Universe
Contact:

Postby Faraz.Fazil » Tue Nov 11, 2003 10:30 pm

These are called dependency errors.
The program you are trying to install , requires some files/packages which are currently not installed on your system.

You need to download and install those dependency rpms.

To do so, goto to an rpm repository like:

1.http://www.rpm.pbone.net
2.www.rpmfind.net
3.tuxfinder.org

enter the missing dependency name in the search box, download the desired rpm, install it using rpm -Uvh command and then install the original rpm again using rpm -Uvh command.

In your case of gaim,

First download and install this rpm:

Download and use this rpm:

ftp://ftp.pbone.net/mirror/dag.wieers.c ... 0.i386.rpm

or if the above doesnt work then:

ftp://ftp.muni.cz/pub/linux/freshrpms/a ... 3.i386.rpm

or

ftp://mirror.pacific.net.au/linux/redha ... 2.i386.rpm

Install it using rpm -Uvh gtkspell-2.0.4-2.i386.rpm

The install that gaim rpm using rpm -Uvh command
It should work.

Dude, i really wish you learn to search the forum before posting.
You always ask questions that have already been answered.

See this thread:

http://www.linuxpakistan.net/forum2x/vi ... light=gaim

B.T.W are you using Mandrake or Redhat.?
Linux for Life!

zaeemarshad
Lieutenant Colonel
Posts: 660
Joined: Sat Jul 06, 2002 12:35 pm
Location: Islamabad
Contact:

Postby zaeemarshad » Wed Nov 12, 2003 12:18 am

i wish rpm had this dependency check and install facility built into it like it is in redhat-config-packages. debian has also got this in their package management system. is there any patch for rpm that enables us to do this?

Regards
Zaeem

ashariqbal
Havaldaar
Posts: 105
Joined: Mon Jun 24, 2002 10:01 am
Location: Karachi

urpmi

Postby ashariqbal » Sat Nov 15, 2003 10:26 am

Mandrake has urpmi which will find and install all dependencies that that available on your CDs

zaeemarshad
Lieutenant Colonel
Posts: 660
Joined: Sat Jul 06, 2002 12:35 pm
Location: Islamabad
Contact:

Postby zaeemarshad » Sat Nov 15, 2003 10:53 pm

RedHat=no urpmi

does installpkg in slackware install all the dependencies? I have yet to experiment with debian and slackware. Debian is on my hit list tonight.

Regards
Zaeem Arshad


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest