HELP! Nvidia Drivers.

General discussion about PLUC and Linux in Pakistan.
Posts: 5
Joined: Sun Oct 17, 2004 1:40 pm

HELP! Nvidia Drivers.

Postby waqassonic » Mon Oct 18, 2004 10:00 pm

I am quiet new to linux.....i installed mandrake 9.0 and when it configures the vga card it does not display my card i.e Nvidia 5900 xt, the problem is that even if i get the drivers from the nvidia's website i cannot still load linux as it gives a display error i.e check/change ur settings X-(something) cannot load.....please help me get inside mandrake just once then i will try to update the drivers.

Lieutenant Colonel
Posts: 691
Joined: Mon Oct 13, 2003 9:40 am

Postby jargon » Mon Oct 18, 2004 11:12 pm

well have you installed the drivers from properly?
if so then you have to read the README file that comes with it from the site, it will tell you exactly what to do, how to edit your XF86Config file to set the proper drivers so that X11 will load properly. ... README.txt ... -6111.html

Major General
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
Location: Karachi/Pakistan/Earth/Universe

Postby Faraz.Fazil » Tue Oct 19, 2004 12:16 am

I am also running a system with an NVIDIA AGP...successfully in linux.
Here is the correct method:

get the appropriate driver from the nvidia linux jargon pointed.

most prolly: ...

or ...

depending on which card u have..

once u have download the driver..

login as root and then


it will start the auto driver installation.It will say no precompied kernel driver will give the option to compile yes..within 20 seconds...the process will be finished ...and then all u need to do is to edit /etc/XF86Config and change driver "nv" to driver "nvidia"

(Driver nv can be different, based on ur probed any case u need to set it to driver nvidia)
Linux for Life!

Posts: 77
Joined: Wed Nov 12, 2003 5:37 am
Location: Lahore, Pakistan

Postby linx9 » Wed Oct 20, 2004 4:51 am

normally you have to look for XFree86 file or if you're using a newer kernel the "" file. In which you'll need to edit these:

To find the file, here's the path: /etc/X11/XF86Config

Change Driver "nv"
(or Driver "vesa")


Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

Once you have configured your X config file, save the changes and then you are ready to restart X and begin using the accelerated OpenGL libraries. After you restart X, you should be able to run any OpenGL application and it will automatically use the new NVIDIA libraries.

Battalion Havaldaar Major
Posts: 267
Joined: Tue Nov 18, 2003 10:28 am
Location: Rampuria Mansion

Postby abdul_mateen » Wed Oct 20, 2004 7:26 pm

linx9 wrote:using newer kernel the "" file. In which you'll need to edit these:

To find the file, here's the path: /etc/X11/XF86Config


man in X.Org u have to edit its /etc/X11/xorg.conf
Please correct me if i am wrong at any point.
Abdul Mateen,
Google Android Developer & Linux Administrator
Addictive Mobility,CA

Naib Subedar
Posts: 344
Joined: Sat Apr 10, 2004 9:07 pm
Location: Karachi

Postby saquib_javed » Thu Oct 21, 2004 9:44 am

Yes abdul_mateen

in some distros it's xorg.conf and in some XF86Config

Use Linux and feel Free.
Feel free to use Linux. ;)

Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest