GNOME Starting problem

General discussion about PLUC and Linux in Pakistan.

GNOME Starting problem

Postby asaddotcom » Mon Aug 15, 2005 7:33 pm

Assalam_O_Alaikum !

I have problem when i was login my GNOME box. after to enter root user name and password it was look still and donot move . please anyone tell me the problem ?
what can i do ?

I was remember i got this problem after i apply this command :

Code: Select all

#chown squid:squid /usr/local/squid/sbin/cache

after to apply this command my squid is stop working .. i was worried then again i was apply this command

Code: Select all

#chown nobody:nobody /usr/local/squid/sbin/cache
then i was able to access my squid but i got GNOME login problem and named service starting problem.

my named service is also not working when was i try to apply this command

Code: Select all

service named reload
or

Code: Select all

service named start
or

Code: Select all

service named stop

I was got this messege

[root@asad root] service named reload
Reloading named: 1794: no process killed [FAILED]


[root@asad root] service named stop
stopping named: rndc: connect failed: timed out [FAILED]


[root@asad root] service named start [ OK ]


My KDE box is working but not GNOME
Please tell me about these problems. how to recover named service and GNOME box
I am using RedHat 9

Allah Hafiz
Thanking You...

ครค๔
www.apnicollection.com | www.wikisoft.pk
asaddotcom
Company Havaldaar Major
 
Posts: 195
Joined: Fri Feb 04, 2005 7:21 pm
ICQ: 172131405
Website: http://www.apnicollection.com
WLM: asaddotcom@msn.com
Yahoo Messenger: asaddotcom2002@yahoo.com
AOL: AsadDotCom
Location: Lahore, PK

Re:

Postby LinuxFreaK » Tue Aug 16, 2005 1:04 am

Dear asaddotcom,
Salam,

I belived your named does not start at Linux Startup if it is then show me the output of this command.

# chkconfig --list named

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Re:

Postby asaddotcom » Thu Aug 18, 2005 5:22 am

LinuxFreaK wrote:Dear asaddotcom,
Salam,

I belived your named does not start at Linux Startup if it is then show me the output of this command.

# chkconfig --list named

Best Regards.


Sallam LinuxFreak

I have applied this command and its says :

[root@asad root]# chkconfig --list named
named 0:off 1:off 2:off 3:off 4:off 5: on 6:off

now tell me what can i to do ?

waiting to hear from you..

Allah Hafiz
Thanking You...



ครค๔

www.apnicollection.com | www.wikisoft.pk
asaddotcom
Company Havaldaar Major
 
Posts: 195
Joined: Fri Feb 04, 2005 7:21 pm
ICQ: 172131405
Website: http://www.apnicollection.com
WLM: asaddotcom@msn.com
Yahoo Messenger: asaddotcom2002@yahoo.com
AOL: AsadDotCom
Location: Lahore, PK

Re:

Postby LinuxFreaK » Thu Aug 18, 2005 7:31 am

Dear asaddotcom,
Salam,

[root@asad root]# chkconfig --list named
named 0:off 1:off 2:off 3:off 4:off 5: on 6:off


The above output shows that you named service not running when you are in run level 3 so you need to follow this command !!

# chkconfig --level 3 named on

Reboot your machine and test again :)

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Re:

Postby asaddotcom » Thu Aug 18, 2005 8:18 pm

LinuxFreaK wrote:Dear asaddotcom,
Salam,

[root@asad root]# chkconfig --list named
named 0:off 1:off 2:off 3:off 4:off 5: on 6:off


The above output shows that you named service not running when you are in run level 3 so you need to follow this command !!

# chkconfig --level 3 named on

Reboot your machine and test again :)

Best Regards.


Dear LinuxFreak

nothing happened after apply this command and rebooting got the same problem.

[root@Microsoft root]# service named reload
Reloading named: 1787: no process killed
[FAILED]

[root@Microsoft root]# service named stop
Stopping named: rndc: connect failed: timed out
[ FAILED ]


[root@Microsoft root]# service named start
[root@Microsoft root]# [ OK ]


Please tell me about the problem... pata nahi kya hoga hai isko...:(
Thanking You...



ครค๔

www.apnicollection.com | www.wikisoft.pk
asaddotcom
Company Havaldaar Major
 
Posts: 195
Joined: Fri Feb 04, 2005 7:21 pm
ICQ: 172131405
Website: http://www.apnicollection.com
WLM: asaddotcom@msn.com
Yahoo Messenger: asaddotcom2002@yahoo.com
AOL: AsadDotCom
Location: Lahore, PK

Re:

Postby LinuxFreaK » Thu Aug 18, 2005 11:06 pm

Dear asaddotcom,
Salam,

Do Post your Configuration files and also check your logs !!

# tail -f /var/log/message

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Re:

Postby asaddotcom » Sat Aug 20, 2005 12:45 pm

LinuxFreaK wrote:Dear asaddotcom,
Salam,

Do Post your Configuration files and also check your logs !!

# tail -f /var/log/message

Best Regards.


Sallam LinuxFreak,

I have seen tail -f /var/log/messeges file a little bit view is:
[root@Microsoft root]# tail -f /var/log/messages
Aug 20 12:39:06 Microsoft dhcpd: Dynamic and static leases present for 192.168.2.18.
Aug 20 12:39:06 Microsoft dhcpd: Remove host declaration P-71 or remove 192.168.2.18
Aug 20 12:39:06 Microsoft dhcpd: from the dynamic address pool for 192.168.2.0/24
Aug 20 12:39:06 Microsoft dhcpd: DHCPREQUEST for 192.168.2.18 from 00:50:8b:04:2f:cd via eth0
Aug 20 12:39:06 Microsoft dhcpd: DHCPACK on 192.168.2.18 to 00:50:8b:04:2f:cd via eth0
Aug 20 12:39:17 Microsoft dhcpd: Dynamic and static leases present for 192.168.2.32.
Aug 20 12:39:17 Microsoft dhcpd: Remove host declaration Zeshan or remove 192.168.2.32
Aug 20 12:39:17 Microsoft dhcpd: from the dynamic address pool for 192.168.2.0/24
Aug 20 12:39:17 Microsoft dhcpd: DHCPREQUEST for 192.168.2.32 from 00:50:ba:d0:2f:b3 via eth0
Aug 20 12:39:17 Microsoft dhcpd: DHCPACK on 192.168.2.32 to 00:50:ba:d0:2f:b3 via eth0
Aug 20 12:39:25 Microsoft dhcpd: Dynamic and static leases present for 192.168.2.35.
Aug 20 12:39:25 Microsoft dhcpd: Remove host declaration LapTop or remove 192.168.2.35
Aug 20 12:39:25 Microsoft dhcpd: from the dynamic address pool for 192.168.2.0/24
Aug 20 12:39:25 Microsoft dhcpd: DHCPREQUEST for 192.168.2.35 from 00:50:04:1b:4b:34 via eth0
Aug 20 12:39:25 Microsoft dhcpd: DHCPACK on 192.168.2.35 to 00:50:04:1b:4b:34 via eth0
Aug 20 12:39:46 Microsoft dhcpd: Dynamic and static leases present for 192.168.2.2.
Aug 20 12:39:46 Microsoft dhcpd: Remove host declaration office-client or remove 192.168.2.2
Aug 20 12:39:46 Microsoft dhcpd: from the dynamic address pool for 192.168.2.0/24
Aug 20 12:39:46 Microsoft dhcpd: DHCPREQUEST for 192.168.2.2 from 00:07:e9:5a:bc:18 via eth0
Aug 20 12:39:46 Microsoft dhcpd: DHCPACK on 192.168.2.2 to 00:07:e9:5a:bc:18 via eth0
Aug 20 12:40:09 Microsoft dhcpd: Dynamic and static leases present for 192.168.2.37.
Aug 20 12:40:09 Microsoft dhcpd: Remove host declaration Flat-no-4-2 or remove 192.168.2.37
Aug 20 12:40:09 Microsoft dhcpd: from the dynamic address pool for 192.168.2.0/24
Aug 20 12:40:09 Microsoft dhcpd: DHCPREQUEST for 192.168.2.37 from 00:0a:e6:4b:81:fb via eth0
Aug 20 12:40:09 Microsoft dhcpd: DHCPACK on 192.168.2.37 to 00:0a:e6:4b:81:fb via eth0


Please tell me what does it error mean ???

and also tell me which configuration file i will post here??

Like Squid.conf , /etc/named.conf, /etc/dhcpd.conf or what else ?
Rgds.

Asad Ali
Thanking You...



ครค๔

www.apnicollection.com | www.wikisoft.pk
asaddotcom
Company Havaldaar Major
 
Posts: 195
Joined: Fri Feb 04, 2005 7:21 pm
ICQ: 172131405
Website: http://www.apnicollection.com
WLM: asaddotcom@msn.com
Yahoo Messenger: asaddotcom2002@yahoo.com
AOL: AsadDotCom
Location: Lahore, PK

Re:

Postby LinuxFreaK » Sun Aug 21, 2005 12:51 am

Dear asaddotcom,
Salam,

Please start your named service and monitor your logs on another terminal !!

Your current logs show nothing about DNS.

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Re: GNOME Starting problem

Postby Mohtashim » Mon Aug 22, 2005 12:42 pm

application of chown should not have any impact on any ohter files than in
that /usr/local/squid/sbin/cache directory, theroratically.
are you sure you did nothing other than chowning ?
secondly, when you "reload" some service, it first tries to stop that service
and then it tries to start it. so if it was not satarted already, then no
wonder why you see FAILED messeges on stoping or reloading commands.

as LF said, try to locate the problem in log files.
your given log messege's log dosnt showy anything other than dhcp messeges, which is not your problem.

try "dmesg > boot_log.txt" and post it the contet of that "boot_log.txt" file here, may be them someone be able to trace the root of your namd problem.

for gnome problem, you'll most certainly find your solution again in logs.
let us know

unfotunatly i use Debian as my linux and not RH, so i cant help you directly.

regards
Mohtashim
Lance Naik
 
Posts: 15
Joined: Tue Jun 21, 2005 4:03 pm
WLM: mohtashim_shadmani@hotmail.com
Location: Karachi

Re:

Postby asaddotcom » Mon Aug 22, 2005 6:28 pm

LinuxFreaK wrote:Dear asaddotcom,
Salam,

Please start your named service and monitor your logs on another terminal !!

Your current logs show nothing about DNS.

Best Regards.


Dear LinuxFreak Assalam_O_Alaikum!

Dear Farrukh i have applied this command : service named restart
and furtherly check log file : tail -f /var/log/message . its say:
Aug 22 18:21:36 Microsoft named: named shutdown failed
Aug 22 18:21:39 Microsoft named[27288]: starting BIND 9.2.1 -u named
Aug 22 18:21:39 Microsoft named[27288]: using 1 CPU
Aug 22 18:21:39 Microsoft named: named startup succeeded
Aug 22 18:21:39 Microsoft named[27288]: loading configuration from '/etc/named.conf'
Aug 22 18:21:39 Microsoft named[27288]: no IPv6 interfaces found
Aug 22 18:21:39 Microsoft named[27288]: listening on IPv4 interface lo, 127.0.0.1#53
Aug 22 18:21:39 Microsoft named[27288]: listening on IPv4 interface eth0, 192.168.2.1#53
Aug 22 18:21:39 Microsoft named[27288]: listening on IPv4 interface eth1, 192.168.1.2#53
Aug 22 18:21:39 Microsoft named[27288]: command channel listening on 127.0.0.1#953
Aug 22 18:21:39 Microsoft named[27288]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
Aug 22 18:21:39 Microsoft named[27288]: zone localhost/IN: loaded serial 42
Aug 22 18:21:39 Microsoft named[27288]: running


now please check log and tell me reason why this ia react like that ..

Allah Hafiz..

Rgds.

Asad Ali
Thanking You...



ครค๔

www.apnicollection.com | www.wikisoft.pk
asaddotcom
Company Havaldaar Major
 
Posts: 195
Joined: Fri Feb 04, 2005 7:21 pm
ICQ: 172131405
Website: http://www.apnicollection.com
WLM: asaddotcom@msn.com
Yahoo Messenger: asaddotcom2002@yahoo.com
AOL: AsadDotCom
Location: Lahore, PK

Re:

Postby LinuxFreaK » Tue Aug 23, 2005 1:01 am

Dear asaddotcom,
Salam,

Aug 22 18:21:36 Microsoft named: named shutdown failed
Aug 22 18:21:39 Microsoft named[27288]: starting BIND 9.2.1 -u named
Aug 22 18:21:39 Microsoft named[27288]: using 1 CPU
Aug 22 18:21:39 Microsoft named: named startup succeeded
Aug 22 18:21:39 Microsoft named[27288]: loading configuration from '/etc/named.conf'
Aug 22 18:21:39 Microsoft named[27288]: no IPv6 interfaces found
Aug 22 18:21:39 Microsoft named[27288]: listening on IPv4 interface lo, 127.0.0.1#53
Aug 22 18:21:39 Microsoft named[27288]: listening on IPv4 interface eth0, 192.168.2.1#53
Aug 22 18:21:39 Microsoft named[27288]: listening on IPv4 interface eth1, 192.168.1.2#53
Aug 22 18:21:39 Microsoft named[27288]: command channel listening on 127.0.0.1#953
Aug 22 18:21:39 Microsoft named[27288]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
Aug 22 18:21:39 Microsoft named[27288]: zone localhost/IN: loaded serial 42
Aug 22 18:21:39 Microsoft named[27288]: running


I belive your named is working fine !! now try to issue this command and see what is the output you get !!

# service named status

Or

# /etc/rc.d/init.d/named status

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Re:

Postby asaddotcom » Wed Aug 24, 2005 4:00 pm

LinuxFreaK wrote:Dear asaddotcom,
Salam,

I belive your named is working fine !! now try to issue this command and see what is the output you get !!

# service named status

Or

# /etc/rc.d/init.d/named status

Best Regards.


Dear LF Assalam_O_Alaikum !

I have applied this command and this message come :
[root@Microsoft root]# /etc/rc.d/init.d/named status
rndc: connect failed: timed out
[root@Microsoft root]#


AND

[root@Microsoft root]# service named status
rndc: connect failed: timed out
[root@Microsoft root]#


Rgds.

Asad Ali
Thanking You...



ครค๔

www.apnicollection.com | www.wikisoft.pk
asaddotcom
Company Havaldaar Major
 
Posts: 195
Joined: Fri Feb 04, 2005 7:21 pm
ICQ: 172131405
Website: http://www.apnicollection.com
WLM: asaddotcom@msn.com
Yahoo Messenger: asaddotcom2002@yahoo.com
AOL: AsadDotCom
Location: Lahore, PK

Re:

Postby LinuxFreaK » Thu Aug 25, 2005 1:04 am

Dear asaddotcom,
Salam,

Might be your firewall issue !!

but you must take a look into this mailing list !!

https://www.redhat.com/archives/redhat- ... 00633.html

# iptables -F
# ps -ef | grep named
# /etc/init.d/named status


If you get rndc time out then apply this command !!

# rndc-confgen -a -b 512
# /etc/init.d/named restart


Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Re:

Postby asaddotcom » Thu Aug 25, 2005 6:17 pm

LinuxFreaK wrote:Salam,

Might be your firewall issue !!

# iptables -F
# ps -ef | grep named
# /etc/init.d/named status



Dear LinuxFreak Sallam,

I have apply these commands and result is:

[root@Microsoft root]# iptables -F

[root@Microsoft root]# ps -ef | grep named
named 10972 1 0 18:07 ? 00:00:00 [named]
root 10991 10809 0 18:11 pts/1 00:00:00 grep named

[root@Microsoft root]# /etc/init.d/named status
number of zones: 4
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
server is up and running
[root@Microsoft root]#

:lol:
Thanking You...



ครค๔

www.apnicollection.com | www.wikisoft.pk
asaddotcom
Company Havaldaar Major
 
Posts: 195
Joined: Fri Feb 04, 2005 7:21 pm
ICQ: 172131405
Website: http://www.apnicollection.com
WLM: asaddotcom@msn.com
Yahoo Messenger: asaddotcom2002@yahoo.com
AOL: AsadDotCom
Location: Lahore, PK

Re:

Postby LinuxFreaK » Fri Aug 26, 2005 1:09 am

Dear asaddotcom,
Salam,

Working !!

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi


Return to “%s” General

Who is online

Users browsing this forum: No registered users and 1 guest