Page 1 of 1

USB unmount problem

Posted: Thu Feb 15, 2007 8:03 pm
by babarsaed
Salam O Alaikum

how are you all !Brothers

im facing problem when i use my usb device,after mounting whenever i execute following command to unmount my usb, it give following message

#umount /mnt/usb

device busy

what i have to do.plz help


Allah hafiz

Posted: Thu Feb 15, 2007 8:24 pm
by lambda
try lsof /mnt/usb, or something like that. make sure you don't have a shell process (or something else) that has done "cd /mnt/usb". make sure your nautilus or other desktop apps don't have that directory open.

usb umount problem

Posted: Thu Feb 15, 2007 11:59 pm
by babarsaed
Aslam o Alaikum

dear lambda

i tried lsof /mnt/usb but it is not solving problem.
i have to restart my linux box each time when i have to unplug my desktop applicaion was running.

plz help me


Allah hafiz

Posted: Fri Feb 16, 2007 3:17 am
by lambda
try eject /dev/sdc (or whatever).

i can't help you. you have to examine your system and see what's accessing the drive. there is no single simple small list of processes that could block your system from unmounting it -- it can be anything.

Posted: Fri Feb 16, 2007 12:51 pm
by Shahryar
You must close any application that is accessing the /mnt/usb directory. For example if you have a file manager window showing this directory's contents then umount command will not work until you close the window.


Posted: Sat Feb 17, 2007 10:53 am
by LinuxFreaK
Dear babarsaed,

Try following command it will show you what is going on.

# fuser -v /mnt/usb

Best Regards.

USB unmount problem

Posted: Sat Feb 17, 2007 6:15 pm
by babarsaed
Deat Farrukh Bhai

Aslam o Alaikum

thanks alot. my usb unmount problem have been solved. thanks for helping actualy a file created automatically in usb with the name of .trash root. due to that file it was not being unmount. i delete this file and now with #umount /mnt/usb i can unmount my usb device.

thanks alot farrukh bhai


Allah Hafiz.