Alien stuck in Linux world, plz help

Discussion regarding the installation and configuration of Linux distributions.
Posts: 6
Joined: Wed Jul 23, 2003 10:28 am
Location: Lahore

Alien stuck in Linux world, plz help

Postby Dumb » Thu Jul 24, 2003 9:35 pm

Well, first of all ,allow me to say that u people have been doing such a gr8 job here by helping out people with their problems in Linux.
I have been traversing this forum for quite some days and i have a very strong observation that most of the people ove here WANT to help out those who r not knowledgeable as they r.This is indeed a very good show of cander and helpfullness.
That is how , finally , i decided to plung into this forum.
I am a newbie in Linux (using Red Hat Linux 9)and am @ early stages of learning linux.
My system specs are as follows.
1.13GHz intel processor
128 mb sd RAM
intel D815EGEW Desktop Board.(with built in sound card and vga)

This is my first post in this forum. I have certain quiries.(This post is gona be long so b patient..... :-)

Ur help is anticipated.
1)what type of file is *.rpm ?
2)how to use/install these files?
3)I had installed rh linux 9 earlier but x server got busted , due to which grub didn't loaded properly, So, i had to reinstall it.In previous installation , i used to listen to mp3 music with xmms .There wasn't a problem @ all.Now , that , i have reintalled linux,when i tried to run an mp3 file very first time, some window showed up with some legall stuff on”Due to copy right bla bla bla , support for mp3 has been taken out of rh linux 9.”what is this and how can i get my music life back on normal track again?

4) I wanted to run video files on linux but couldn't find any player for that purpose.By searching the net, i came acroos some popular player like xine and mplayer, apt.(Btw, i am not still sure what apt is actaully?)
Now , i have downloaded some files in *.rpm format.
e.g, i have xine with 3 files as listed below.

i have mplayer with
I also have apt in the form of

So, what do i do with these files , so that i can run (primarily) *.dat , *.mpg,*.avi files.
(optionaly dvds).I assume these are installation files. then how to install them, where they will be installed and how will i access them to use em.
Also , if any one know how to configure any of the email program in KDE to configure for hotmail AND yahoo.
plz , keep in mind while answering,that i am totally a newbie in linux. and not familiar with most of the shell commands and some of the gui programs.
Ur replie r anxiously awaited,Thanx in advance.

Posts: 359
Joined: Sun Nov 03, 2002 6:40 am
Location: Lahore

Postby farhanksa » Thu Jul 24, 2003 10:12 pm

welcome to the world of LINUX
Life is not that easy in linux world..but i think u r gona make it ..inshallah
first of all i recomend u to have a book of linux.
u must read the help by using command : man rpm

to install use commnd rpm -iv rpmname.rpm
-i is to install
-v to verbos
pls read the switches in then man

for the x server it some time dies . an easy solution which worked for me is i added another user
by: adduser user1
passwd user1 *****password

then make this uer the group member of the root by
vi /etc/passwd
press insert key to insert soem thing (if u r stuck up press ESC :q! )
there must be some where root ....and replace the group no# user1 with the group no# or root
press escape then : x (to write or save and exit)
and now pls try to run startx after login from the user1

trr.gz is the compressed format of the files to use the command to uncompresss
tar -zxf tarfilename.tar.gz

then cd to the directory by cd tarfilename
and read the read me file by vi readme
usually to install we have to use ./configure
or first make then make install ..u will be clear after reading the readme file

u may have mozilla , kconqurer, netscape as the browsers in KDE ,GNOME
good luck pls red it well before doing operation o fur linux box good luck

Major General
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
Location: Karachi/Pakistan/Earth/Universe

Postby Faraz.Fazil » Fri Jul 25, 2003 12:41 am

Welcome to the world of linux.
Here we go:

rpm files are basically redhat package binaries.Just like windows program setups are in .exe format, programs writtens for redhat linux, their setup is in rpm format.

To install a package/program for linux, you have two options:

1.To downlaod or install its sources in .tar.gz format
2.To download and install it in the distro's propreitary format.Rpm is the standard package format for redhat linux.

Rpms are installed by the command:

rpm -i rpmname.rpm

rpm - U rpmname.rpm

Q-2) MP3 Support:
New versions of xmms dont come with mp3 support by default due to copyright .Worry not.You can still play mp3 files with xmms.All you need to do is to download and install the xmms-mp3 plugin.

Once you download and install the xmms mp3 plugin rpm, xmms will play mp3 files perfectly and your music life will be back to normal.

Q-3) Playing multimedia /video files in linux.
You can play any type of movie formats in linux.Yes its possible.All you need is a good video player for linux.The two good ones are mplayer and xine.
All you need to do is to download the mplayer /xine rpm files from their official websites.

Donot install the file that you yourself downloaded.They are sources in tar.gz format.Installing from sources is always a pain in the neck, and in most times it doesnt install successfully due to some failed dependeny.

Instaead Download all the files in rpm format.I have given the download links of all the mplayer and xine files that u need to download an install below:

The files needed are:

FOr mplayer:
========= ... noarch.rpm ... 1.i386.rpm ... 1.i386.rpm

For xine:

Download and install thr rpms from

Files required: ... 1.i386.rpm ... 1.i386.rpm ... k.i386.rpm ... k.i386.rpm ... 5.i686.rpm ... 5.i586.rpm ... 5.i586.rpm

Codec to play all the files:

Which ever video player xine or mplayer u install, you wont be able to play any files unless you install this codec:

Also download and instal this package if you want to be able to run all windows movie / audio formats on linux including wmv, avi , mpg, vcd etc: ... 1.i386.rpm

Once the video player i.e xine or mplayer and the w32codec is installed, you will be able to play all multimedia files, including vcd, mpg, avi, wmv , divx etc on linux.

Note: install all the rpms one by one using the command rpm -i rpmname.rpm e.g

rpm -i w32-codec-0.52-1.i386.rpm

4.For Email::

Use a webbrowser like netscape for linux or opera for linux to access hotmail/yahoo from their website.You can also check pop based mailz using a pop email client for linux.One such client is Evloution or the builtin opera browser pop based email.

Posts: 6
Joined: Wed Jul 23, 2003 10:28 am
Location: Lahore

yar, more help needed

Postby Dumb » Sun Jul 27, 2003 12:10 am

Thank u farhanksa & Faraz.Fazil Indeed for ur prompt response.
By now, some more quiries have been developed :-)

1)Faraz.Fazil,i downloaded the rpm packeges needed for mplayer.i.e,
But the problem is, when ever i tried to install them , e.g,
i tried to install mplayer-common-0.90-1.i386.rpm , like this ,

root@localhost downlaoded stuff]# rpm -i mplayer-common-0.90-1.i386.rpm
warning: only V3 signatures can be verified, skipping V4 signature
error: Failed dependencies:
mplayer = 0.90 is needed by mplayer-common-0.90-1

This error messege was created.Now, what i concieved that , i should also download mplayer 0.90 , in order to run
other rpms, so i downlaoded

Now , this happened when i tried to install this.

[root@localhost downlaoded stuff]# rpm -i mplayer-0.90.20030530-1.i386.rpm
error: Failed dependencies:
mplayer-common = 0.90.20030530 is needed by mplayer-0.90.20030530-1 is needed by mplayer-0.90.20030530-1

assumebly, both r interdependent on each other.So , how can i install mplayer anyway?
i mean , both these files need the other one 2 b installed first, i mean , what is this, i am totally confused.javascript:emoticon(':?')

2)is there any alternative for windows shortcut ctrl+alt+del to kill some process/appl in linux?
3)On the time of installation , i mounted 1 of my fat32 partition in /mnt/wind , i only have read access ,but no write access ,
why, is this so, and how can i have write access to this partition as well as on some other fat32 partition mounted by
mount -t vfat /dev/hda6 /directory name/directory name ?
Thanx in Advanced. :?
Never Underastimate The Power of BRAIN!

Major General
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
Location: Karachi/Pakistan/Earth/Universe

Postby Faraz.Fazil » Sun Jul 27, 2003 12:09 pm

HI dumb,

I figured out your problem

Answer to Q-1
1.For mplayer,first of all you downloaded one wrong package.YOu downloaded these packages correct: ... 1.i386.rpm ... 1.i386.rpm

But in place of mplayer-0.90.20030530-1.i386.rpm , you should have downloaded ... noarch.rpm
becoz a default skin is requred by mplayer.

In short only and only install these packages for mplayer:


Secondly, NOTE: There are circular dependencies, so you must install them all at once by this command:

rpm -Uvh mplayer-common-0.90-1.i386.rpm mplayer-gui-0.90-1.i386.rpm mplayer-skin-default-1.0-2.noarch.rpm

Make sure all the files are in one directory before issuing this command.If ur filenames are different, replace the filenames i mentioned with the ones u have.

The above method wil definitely work.If that doesnt work then use the command below to install the rpms one by one:

rpm --nodeps -U rpmname.rpm

the above format will skip any dependencies and will install the packages in upgrade mode.

Answer to Q-2
In terminal, just type:


and press enter

It will invoke the redhat service configurator.It will show u the list of all the services.You can start,stop , restart, enable or disable any service from there.Be careful not to stop or disable any critical process.

Another method to invoke the redhat-config-services is to go to the start menu, server settings and then services.

Answer to Q-3:

by default the command mount -t vfat /dev/hdaNumber /mnt/mountpoint mounts the drive in read write mode.If u have a problem then use this format to mount the drive in read write mode:

mount -rw -t vfat /dev/hdaNumber /mnt/MOuntPoint

You can read/write the files to the moounted drive thru the termnial or thru the file manager i.e nautilius

I have explained u each step in detail and i have personally tested it especially the mplayer rpms.

If u still have any problem, feel free to ask.You can even add me on msn/icq/aol if u need real time help.You can losgin to msn/icq/aol thru linux using any good im client like gaim and u can have a chat with me in real time.

Major General
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
Location: Karachi/Pakistan/Earth/Universe

Postby Faraz.Fazil » Tue Jul 29, 2003 6:28 pm

So dumb, did u solve all your problems>?

Also i forgot to mention the link to download xmms-mp3 plugin for playing mp3 files in redhat linux thru xmms: ... 1.i386.rpm

Posts: 6
Joined: Wed Jul 23, 2003 10:28 am
Location: Lahore

Postby Dumb » Thu Jul 31, 2003 1:24 am

yar, most of them are solved , at least , as far as this section of the fourm is concerned ,they r , for now, solved.
Other quires will be posted in respective forum.
Thanx .
(i have downloaded the xmms plugin for mp3.) :D
Never Underastimate The Power of BRAIN!

Major General
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
Location: Karachi/Pakistan/Earth/Universe

Postby Faraz.Fazil » Thu Jul 31, 2003 1:28 pm

Ok.Good to hear that.
If u have any more questions, feel free to ask.

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest