Problem in Installation

Discussion regarding the installation and configuration of Linux distributions.

Problem in Installation

Postby zahid » Thu Aug 07, 2003 9:59 pm

AOA
I am new to linux.
I have Redhat linux 8.0, when delete my partitions, then insert Linux cd1, and start setup.

But it gives me image file error.
I am very confused, anybody can tell me, how to install Redhat Linux?

Thanks in advance
Zahid
zahid
Cadet
 
Posts: 4
Joined: Thu Aug 07, 2003 9:33 pm
Website: http://www.avonix.com/
WLM: zahid_gr8@hotmail.com
Location: Karachi

dont worry ... we welcome u here :)

Postby farhanksa » Fri Aug 08, 2003 12:20 am

aoa
u have to be a bit brave now...welcome.
its recomended that u use the tested cd's released by
linuxpakistan karachi ..they release tested cd's in the market.

well pls check the cd before instalation... when u boot from cd1 it have an option to check the cd...pls go for the checking.. althoug it happened with me that even after checking it didint worked...but it may be the exceptional case.. :)
instalation process is very easy...
u need to have atlease 2 partitions
/ partition type=etx2 or ext3 about 2.5 gb max and swap partition 128 or 256 mb
farhanksa
Subedar
 
Posts: 359
Joined: Sun Nov 03, 2002 6:40 am
ICQ: 116765501
WLM: farhan12@msn.com
Yahoo Messenger: commdsl@yahoo.com
Location: Lahore

:S

Postby zahid » Fri Aug 08, 2003 12:00 pm

AOA
how can i make etx2 or 3 partions????

is there any boot disk? or file like fdisk ???
or something else to do?

Thanks in advance
Zahid
zahid
Cadet
 
Posts: 4
Joined: Thu Aug 07, 2003 9:33 pm
Website: http://www.avonix.com/
WLM: zahid_gr8@hotmail.com
Location: Karachi

u can make it while instalation

Postby farhanksa » Fri Aug 08, 2003 3:28 pm

pls procede with the instalation...pls dont use the automatic partition...use fdisk or disk-druid
farhanksa
Subedar
 
Posts: 359
Joined: Sun Nov 03, 2002 6:40 am
ICQ: 116765501
WLM: farhan12@msn.com
Yahoo Messenger: commdsl@yahoo.com
Location: Lahore

Re: :S

Postby fawad » Fri Aug 08, 2003 7:24 pm

zahid wrote:AOA
how can i make etx2 or 3 partions????

is there any boot disk? or file like fdisk ???
or something else to do?

Thanks in advance
Zahid

Zahid, the Redhat installer is very user friendly. When you get to the partitioning step, select 'Manually Partition' and use Disk Druid. That will do the trick.

And yes, fdisk works too, but there's really no need.
fawad
Site Admin
 
Posts: 918
Joined: Wed Aug 07, 2002 8:00 pm
ICQ: 17672437
Website: http://www.fawad.net
WLM: fawadhalim@hotmail.com
Yahoo Messenger: fawad2048
AOL: fawadhalim
Location: Addison, IL

Thanks

Postby zahid » Sun Aug 10, 2003 8:58 pm

Thanks for help
i installed redhat linux 8.0
and setup is really easy.

But aik aur problem.....
main ne rahim ke account se login kia
[rahim@localhost]_ aaraha hai
main GUI mode per kis tarha switch karoon????


aur haan, aik error bhi aata hai login window ke saath saath

koi Xfree86 ka error aata hai..
but main thing GUI mode per swirch kerna hai

Please help

Thanks in advance
Zahid
zahid
Cadet
 
Posts: 4
Joined: Thu Aug 07, 2003 9:33 pm
Website: http://www.avonix.com/
WLM: zahid_gr8@hotmail.com
Location: Karachi

Postby farhanksa » Mon Aug 11, 2003 1:46 am

u need to configure ur X (gui)
command is Redhat-Config-Xf86 dont remember as me not n rh 8 now :)
but try to get help by pressing tab key after typing the initials of the command.pls dont save the setting to boot in to gui

then u need to switch to gui by comand startx
farhanksa
Subedar
 
Posts: 359
Joined: Sun Nov 03, 2002 6:40 am
ICQ: 116765501
WLM: farhan12@msn.com
Yahoo Messenger: commdsl@yahoo.com
Location: Lahore

Postby Faraz.Fazil » Mon Aug 11, 2003 8:06 am

well, the gui part of linux is mainly xfree86 or simply reffered to as "X"
I assume , you did install xfree86 during install.

IN order for t he gui to run properly, the X server settings should be configured correctly and you should have a compatible display driver install /linked to your /etc/X11/X symbolic link.
Redhat during the install asks you to configure the X settings.Did u configure them?Did it identify your display adapter?

If you are using the correct settings and configuration and you configured the x settings during setup,you just need to invoke the gui by typing startx command in terminal.If u encounter some error, then it means you are using a wrong configuration/driver.In that case you need to configure the X settings by running /usr/bin/redhat-config-xfree86 in terminal.
On some version of redhat, you can also use the xf86 and XConfigurator command to configure your settings of X.Or if you are a seasoned linux user, you can directly tweak/edit your display X settings by editing /etc/X11/XF86Config file.

If nothing works, you may need to get a suitable display driver for linux.Even if thats the case, just post the model and make of your display adapter/vga/agp and we will help you finding a driver...but that is only when you are sure, that your current driver isnt compatible with your display adapt.

As a first attempt. just try running ths gui through startx command.
Post any error messages here.

Also check /etc/X11/Xf86Config file with a text editor like gedit or vim to see if your display adapter has been configured correctly.For instance if you have a s3 virge adapter, it should at some part in the file have identified the adapter.
Faraz.Fazil
Major General
 
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
WLM: faraz7476@hotmail.com
Location: Karachi/Pakistan/Earth/Universe

:S

Postby zahid » Mon Aug 11, 2003 11:36 am

AOA
Main ne wapis install ki linux, aur ho gayee
GUI mode bhi chal raha thaa, 800x600 resolution main.

phir main ne res ko 1024x768 kara
aur pc reset kia tou wapis error aanay laga.

"I cannot start the X Server(Your Graphical Interface). It is likely that it is not setup correctly. Would you like to view the X Server Output to diagnose the problem"
Yes | No

aur Fatal error: No Screens Found. aaraha hai
zahid
Cadet
 
Posts: 4
Joined: Thu Aug 07, 2003 9:33 pm
Website: http://www.avonix.com/
WLM: zahid_gr8@hotmail.com
Location: Karachi

Restor your original Xconfig file

Postby Mustafa » Mon Aug 11, 2003 1:21 pm

Zahid,
whenever you change your X configuration it create a backup of the original file... so you can easily restore your old configuration...you can rename your old config file or you can...its the simplest way ....
i hope you willl do it easily.,,
------------------
mUsTfAh
-
Ghulam Mustafa
Mustafa
Cadet
 
Posts: 12
Joined: Fri Jul 11, 2003 6:48 am
Website: http://www.webtechdezign.com
WLM: mustfah@msn.com
Yahoo Messenger: koool_enigma
Location: Multan

Re: :S

Postby Faraz.Fazil » Mon Aug 11, 2003 1:22 pm

Koi baat naheen.
Kharab naheen karna to seekhna naheen hehehe

Anywayz, i will help u to fix the problem in just 20 seconds.

Method 1:
==========
the easiest method would be to restore the XF86Config backup file that X created when u changed the setting.

The latest config file is at /etc/X11/XF86Config (this it the bad setting file in ur case)
whereas the backup is at /etc/X11/XF86Config.backup (This is the correct file in ur case)
All you have to do is issue these commands in terminal:

rm /etc/X11/XF86Config
cp /etc/X11/XF86Config.backup /etc/X11/XF86Config

Thats it.Reboot and voila it will work

Or if u dont have a backup or u want to try something else then:
(the second method is more difficult)

Method2:
========
The problem is you configured linux to use a 1024 resolution which ur display adapter doesnt support.So we need to set it back to 800 x 600.

Invoke linux in terminal mode.You have two options to do this.The easiest option is when it displayes the error : "Would you like to view the X Server Output to diagnose the problem"", select no.It will bring you to terminal mode.Enter the user name and password.
Then open the /etc/X11/XF86Config file using any editor like emacs, gedit or vim.

e.g gedit /etc/X11/XF86Config
or emacs /etc/X11/XF86Config

Look for the section "Screen"

There will be the resolution listed as 1024.Remove 1024 and make it this way:

Depth 16
Modes "800x600" "640x480"

Thats it.Save the file thru the editor, reboot and your pc will be back to normal using the 800 mode again.

For example my Config file for 800 x 600 mode looks like:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

An alternative way to start linux in terminal mode and do this operation is :

1.If you are using lilo as the bootloader.Check the image name for linux>You can do it by pressing the tab key.It will show something like"linux" for linux and "winxp" for windows xp.Once you know the image name, on the main lilo boot screen, specify a custom command as imagename 3

This will start linux in terminal mode (mode 3)

e.g on one of my systems linux 3 starts linux in terminal mode.

2.If u are using grub as the botloader,then You would add init=3 to the kernel line. Like this:

title Red Hat Linux (2.4.9-31) (b)Runlevel3(/b)
root (hd2,0)
kernel /boot/vmlinuz-2.4.9-31 ro root=/dev/hdd1 hdc=ide-scsi (b)init=3(/b)
initrd /boot/initrd-2.4.9-31.img

(Replace the brackets in (b) with square brackets.I couldnt post square brackets in this post, becoz phpbb would convert them to bold text.)

"So the easiest method is the first method i.just restore a backup.

Good luck!

If u cant get some point or want more help, just add me on msn: faraz7476@hotmail.com
and i will help u solve the problem, even if u are a total newbie.

zahid wrote:AOA
Main ne wapis install ki linux, aur ho gayee
GUI mode bhi chal raha thaa, 800x600 resolution main.

phir main ne res ko 1024x768 kara
aur pc reset kia tou wapis error aanay laga.

"I cannot start the X Server(Your Graphical Interface). It is likely that it is not setup correctly. Would you like to view the X Server Output to diagnose the problem"
Yes | No

aur Fatal error: No Screens Found. aaraha hai
Faraz.Fazil
Major General
 
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
WLM: faraz7476@hotmail.com
Location: Karachi/Pakistan/Earth/Universe


Return to “%s” Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron