post kernel compile bootup problem

Discussion regarding the installation and configuration of Linux distributions.

post kernel compile bootup problem

Postby outstream » Tue Jan 09, 2007 3:18 pm

AoA,

I`m using Slackware 11.0 . I compiled kernel 2.6.17.13 from sources.
These are the steps I followed for kernel compilation.

1. Install the package:

installpkg kernel-source-2.4.26-noarch-4.tgz

2. Taking backup

cp /boot/vmlinuz /boot/vmlinuzOLD
cp /boot/config /boot/configOLD
cp /boot/System.map /boot/SystemOLD.map
mv /lib/modules/2.4.33 /lib/modules/2.4.33OLD

3. remove the current link
rm /usr/src/linux

4. add new link
ln -s /usr/src/linux-2.6.17.13 /usr/src/linux

5. cd /usr/src/linux

6. make mrproper

7. make xconfig

8. make dep ; make clean ; make bzImage

9. make modules ; make modules_install

10. cp arch/i386/boot/bzImage /boot/vmlinuz

Install system map

11. cp System.map /boot

Reinstall lilo

12. lilo



After all this when i rebooted the machine, and selected linux from lilo the screen goes blank..nothing at all..not even a blinking blank cursor.

any ideas?

Thanks.
Testing?What's that? If it compiles, its good, if it boots up it is perfect.
----------------------------------------------------
Imran
Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby kbukhari » Tue Jan 09, 2007 4:14 pm

looks ok
what kernel configuration you used ?
--
Syed Kashif Ali Bukhari
+92-345-8444420
http://sysadminsline.com
http://kashifbukhari.com
kbukhari
Major General
 
Posts: 1222
Joined: Sat Dec 31, 2005 12:29 am
Website: http://kashifbukhari.com
Location: Lahore

Postby outstream » Tue Jan 09, 2007 4:33 pm

default one..the only change i made was on usb 2.0 support.
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby kbukhari » Tue Jan 09, 2007 4:40 pm

try droping these steps
6. make mrproper

and use make all instead of . make dep ; make clean ; make bzImage
--

Syed Kashif Ali Bukhari

+92-345-8444420

http://sysadminsline.com

http://kashifbukhari.com
kbukhari
Major General
 
Posts: 1222
Joined: Sat Dec 31, 2005 12:29 am
Website: http://kashifbukhari.com
Location: Lahore

Postby outstream » Tue Jan 09, 2007 4:52 pm

hmm alright...but i cant do that unless i get into my box. right now i cant access it. its just blank black screen. its not even writing any error messages, not even the famous kernel panic one. its just blank
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby usamahashimi » Wed Jan 10, 2007 1:03 am

Hi
Maybe you can use your bootable CD and load the old files from /boot into lilo.
Thanks
usamahashimi
 

Postby outstream » Fri Jan 12, 2007 12:01 pm

Hi,

yeah, i did that, and it boots from old kernel. I did some search over it on google and came across this post in which a guy said that, he fixed same problem by setting vga = 0 in lilo.conf. I tried doing that but it didnt solve my problem. So i set it back to vga = 773.

here is how my lilo.conf looks like

Code: Select all

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
 message = /boot/boot_message.txt
prompt
timeout = 1200
#Override dangerous defaults that rewrite the partition table:

change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/hda1
  label = Windows
  table = /dev/hda
# Windows bootable partition config ends

# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda7
  label = Linux
  read-only
# Linux bootable partition config ends
# Linux old begins
 image = /boot/vmlinuzOLD
 root = /dev/hda7
 label = Old
 read-only
#Linux old ends


I still dont know how to make my machine boot from new kernel
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby outstream » Fri Jan 12, 2007 4:30 pm

Hi,

I just finished recompiling it for the third time. This time I enabled framebuffer, vga,vesa and also enabled intel 810/45/865 (experimental).

Now, the kernel loads, I can see all those messages while its loading, but suddenly these lines appear

Code: Select all

VFS: cannot open root device "307" or unknown-block93,7)

Please append a correct "root=" boot option

Kernel panic - not syncing: VFS :unable to mount root fs on unknown-block(3,7)


what do i do now? how do i make it not panic :roll:
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby lambda » Fri Jan 12, 2007 5:43 pm

add

Code: Select all

append= "root=/dev/hda7"
below "root = /dev/hda7" in your menu item definitions.
lambda
Major General
 
Posts: 3452
Joined: Tue May 27, 2003 7:04 pm
Website: http://www.hungry.com/~fn/
Location: Lahore

Postby outstream » Fri Jan 12, 2007 6:00 pm

Hi,

It didnt work, still same problem exists. Here is how a part of my boot loader looks like

Code: Select all

# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda7
  append = "root = /dev/hda7"
  label = Linux
  read-only
# Linux bootable partition config ends


Its still giving same VFS, kernel panic error.

Since all my linux drives are ext2, I recompiled kernel for 4th time today and made sure that all entries for ext2 are enabled as "Y" and not as "M".
still same problem continues...
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Re:

Postby LinuxFreaK » Sat Jan 13, 2007 10:46 am

Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Postby outstream » Mon Jan 15, 2007 12:32 pm

Alright, its fixed.

Thanks LinuxFreaK, lambda, usamahashimi, kbukhari.
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby lambda » Mon Jan 15, 2007 1:17 pm

what was the final fix?
lambda
Major General
 
Posts: 3452
Joined: Tue May 27, 2003 7:04 pm
Website: http://www.hungry.com/~fn/
Location: Lahore

Postby outstream » Mon Jan 15, 2007 1:23 pm

Final fix was enabling filesystems as "y", both ext2 and ext3, and everything related to them enabled as "y".
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby lambda » Mon Jan 15, 2007 1:53 pm

i'm surprised that slackware's default kernel doesn't support usb 2 out of the box. in fact, i'm surprised that you had to recompile for anything. the last time i had to build my own kernel was in 2003 or so, when i had to use a patched 2.4 kernel for xfs (2.4 didn't ship with xfs).
lambda
Major General
 
Posts: 3452
Joined: Tue May 27, 2003 7:04 pm
Website: http://www.hungry.com/~fn/
Location: Lahore


Return to “%s” Installation

Who is online

Users browsing this forum: No registered users and 2 guests

cron