agt-get and yum.

Discussion regarding the installation and configuration of Linux distributions.

agt-get and yum.

Postby azfar » Fri Jan 19, 2007 5:12 pm

I am on fedora and want to install a software which mainly install its dependencies from apt-get (on debian). I want to know can I install these packages from yum or can I install and configure apt-get on fedora.
Azfar Hashmi
Email : azfarhashmi@hotmail.com
azfar
Captain
 
Posts: 598
Joined: Tue Mar 23, 2004 1:16 am
WLM: azfarhashmi@hotmail.com
Yahoo Messenger: azfarhusain@yahoo.com
Location: Karachi

Postby lambda » Fri Jan 19, 2007 6:25 pm

apt-get works on debian-based distributions only. what package is it? yum takes care of dependencies, wherever possible.
lambda
Major General
 
Posts: 3452
Joined: Tue May 27, 2003 7:04 pm
Website: http://www.hungry.com/~fn/
Location: Lahore

Postby Shahryar » Sat Jan 20, 2007 1:01 pm

install a program called "alien". Alien can convert deb package to rpm.
--
S.S.
--
Shahryar
Naik
 
Posts: 81
Joined: Sat Nov 08, 2003 2:49 pm
Website: http://www.ksugar.com
WLM: saigol7@hotmail.com
Location: Lahore

Re:

Postby LinuxFreaK » Mon Jan 22, 2007 9:32 am

Dear azfar,
Salam,

FYI, http://aplawrence.com/Linux/aptget.html

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

apt works

Postby mushtaq » Mon Mar 19, 2007 7:49 am

Asalamualikum to all,

brothers for your information apt works for redhat as well but the repositories are different from that of debian. Redhat has there own repositories.

yum -y install apt

will solve your problem once installed you can simply use

apt-get update

apt-cache search xyz

apt-get install

;)

have a nice day

Best regds
mushtaq
Life is just a deception from truth
mushtaq
Havaldaar
 
Posts: 144
Joined: Sat Jul 01, 2006 10:55 am
Location: karachi

apt-get problem

Postby sarthor » Fri Apr 06, 2007 5:01 pm

Salam O Alykum,

Facing problem about apt-get on ubuntu edgy, 6.10,
root@sarthor:~# apt-get -y install macchanger
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
ymessenger: Depends: libgdk-pixbuf2 (>= 0.13.0) but it is not going to be installed
Depends: libgtk1.2 (>= 1.2.0) but it is not going to be installed
Depends: libssl0.9.6 but it is not installable
Depends: xlibs (> 3.3.6) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


Waiting for your replies.
Thank you all.
Allah Hafiz.
Tefl E Maktab
-----------------------------
----- ----- ----- ------ ------ -------
sarthor
Battalion Quarter Master Havaldaar
 
Posts: 241
Joined: Wed Dec 24, 2003 2:36 am
ICQ: 163419827
Website: http://amazai.net
WLM: sarthor@hotmail.com
Yahoo Messenger: baidaraka@yahoo.com
Location: Pukhtoonistan

Postby barlas » Fri Apr 06, 2007 6:34 pm

Did you try running

Code: Select all

apt-get -f install
? o_O
Aqeel Zafar
barlas
Naib Subedar
 
Posts: 315
Joined: Mon Jun 30, 2003 11:07 am
Website: http://aqeeliz.com
Location: Lahore, Pakistan

Postby sarthor » Fri Apr 06, 2007 7:14 pm

barlas wrote:Did you try running

Code: Select all

apt-get -f install
? o_O


Salam O Alykum
How are you barlas,

root@sarthor:~# apt-get -f install macchanger
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
ymessenger: Depends: libgdk-pixbuf2 (>= 0.13.0) but it is not going to be installed
Depends: libgtk1.2 (>= 1.2.0) but it is not going to be installed
Depends: libssl0.9.6 but it is not installable
Depends: xlibs (> 3.3.6) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Yaar ymessenger beech main kaheen pas gia. .. Wo kehtay hain na keh ... Kuch Chakki Kharab thi.. or kuch Gandum main nami thi..
Me and ubuntu both are new for one another.
Thank you,
Allah Hafiz.
Tefl E Maktab

-----------------------------

----- ----- ----- ------ ------ -------
sarthor
Battalion Quarter Master Havaldaar
 
Posts: 241
Joined: Wed Dec 24, 2003 2:36 am
ICQ: 163419827
Website: http://amazai.net
WLM: sarthor@hotmail.com
Yahoo Messenger: baidaraka@yahoo.com
Location: Pukhtoonistan

Re:

Postby LinuxFreaK » Sat Apr 07, 2007 11:16 am

Dear sarthor,
Salam,

I believe you should install following packages libgdk-pixbuf2, libgtk1.2, libssl0.9.6 and xlibs.

# apt-get install libgdk-pixbuf2 libgtk1.2 libssl0.9.6 xlibs

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Re:

Postby sarthor » Sat Apr 07, 2007 4:23 pm

LinuxFreaK wrote:Dear sarthor,
Salam,

I believe you should install following packages libgdk-pixbuf2, libgtk1.2, libssl0.9.6 and xlibs.

# apt-get install libgdk-pixbuf2 libgtk1.2 libssl0.9.6 xlibs

Best Regards.

Salam O Alykum LinuxFreak
root@sarthor:~# apt-get install libgdk-pixbuf2 libgtk1.2 libssl0.9.6 xlibs
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libssl0.9.6 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libssl0.9.6 has no installation candidate
root@sarthor:~# apt-get install libgdk-pixbuf2 libgtk1.2 xlibs
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package xlibs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libxft1 xkb-data
E: Package xlibs has no installation candidate
root@sarthor:~# apt-get install libgdk-pixbuf2 libgtk1.2
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
libgtk1.2: Depends: libgtk1.2-common (>= 1.2.10-18) but it is not going to be installed
ymessenger: Depends: libssl0.9.6 but it is not installable
Depends: xlibs (> 3.3.6) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Tefl E Maktab

-----------------------------

----- ----- ----- ------ ------ -------
sarthor
Battalion Quarter Master Havaldaar
 
Posts: 241
Joined: Wed Dec 24, 2003 2:36 am
ICQ: 163419827
Website: http://amazai.net
WLM: sarthor@hotmail.com
Yahoo Messenger: baidaraka@yahoo.com
Location: Pukhtoonistan

Postby sarthor » Sat Apr 07, 2007 4:47 pm

Salam O Alykum
Thank you LinuxFreak
The problem sloved,

#apt-get -f install Worked great, (with no pkg,)

Thank you Brother for helping Me as well others,
Allah Hafiz.
Tefl E Maktab

-----------------------------

----- ----- ----- ------ ------ -------
sarthor
Battalion Quarter Master Havaldaar
 
Posts: 241
Joined: Wed Dec 24, 2003 2:36 am
ICQ: 163419827
Website: http://amazai.net
WLM: sarthor@hotmail.com
Yahoo Messenger: baidaraka@yahoo.com
Location: Pukhtoonistan


Return to “%s” Installation

Who is online

Users browsing this forum: No registered users and 2 guests

cron