Not Browsing in Linux Machine

Discussion regarding the installation and configuration of Linux distributions.
Siraj Ahmed
Lance Naik
Posts: 25
Joined: Thu Dec 08, 2005 10:22 pm
Location: New Karachi
Contact:

Not Browsing in Linux Machine

Postby Siraj Ahmed » Sun Feb 18, 2007 4:14 pm

Assalam o Alykum

mere pass 2 machine hai ek windows2000 Professional aur ek
Linux Enter Prize 3
windows2000 per net connect hai modem k through aur Lan card ki
ip = 192.168.0.1
sn = 255.255.255.0

Linux ki machine
eth0 = ip = 192.168.0.2 connected to windows 2000
sn = 255.255.255.0

eth1 = ip = 10.0.0.1 connected to Lan user (Client)
sn = 255.0.0.0

squid = running properly

?? linux ki machine per bhi browsing nahi ho rahi aur client ki machine per bhi browsing nahi ho rahi


linnux ki machine per browser mai direct bhi browsing nahi ho rahi aur proxy dalney ke bad bhi nahi ho rahi 10.0.0.1 3128
yehi problem client machine per bhi ho rahi hai

[-RHEL-]
Cadet
Posts: 9
Joined: Fri Jan 19, 2007 7:24 am
Location: Lahore
Contact:

Postby [-RHEL-] » Sun Feb 18, 2007 6:06 pm

AOA

see Again...( iss ko dobara dakhoo dear..)
koi mistake hoo gayi app ke...

http://www.linuxpakistan.net/forum2x/vi ... php?t=6600

ager app ke linux per bro.. nahi hoo rahi to try..
# nslookup yahoo.com
# host yahoo.com
...
# links yahoo.com..

Best Regards
SroNey
Windows : "Where do you want to go today?." Linux : "Where do you want to go tomorrow?." FreeBSD : "Are you guys coming what?."

Siraj Ahmed
Lance Naik
Posts: 25
Joined: Thu Dec 08, 2005 10:22 pm
Location: New Karachi
Contact:

Postby Siraj Ahmed » Sun Feb 18, 2007 7:11 pm

mainey etney sarary iptables ki commnad applies ki hai k sara system disturb ho chuka hai koi aisi commnad hai jis sey mai sari iptables ki commands ko remove kar sakoo aur new iptables ko apply karoo

thecooldude
Lance Naik
Posts: 43
Joined: Sun Nov 26, 2006 6:04 pm
Location: Dubai, UAE.
Contact:

Dear Siraj Ahmed.

Postby thecooldude » Mon Feb 19, 2007 1:11 am

Assalam o Alykum

mere pass 2 machine hai ek windows2000 Professional aur ek
Linux Enter Prize 3
windows2000 per net connect hai modem k through aur Lan card ki
ip = 192.168.0.1
sn = 255.255.255.0

Linux ki machine
eth0 = ip = 192.168.0.2 connected to windows 2000
sn = 255.255.255.0

eth1 = ip = 10.0.0.1 connected to Lan user (Client)
sn = 255.0.0.0

squid = running properly

?? linux ki machine per bhi browsing nahi ho rahi aur client ki machine per bhi browsing nahi ho rahi


linnux ki machine per browser mai direct bhi browsing nahi ho rahi aur proxy dalney ke bad bhi nahi ho rahi 10.0.0.1 3128
yehi problem client machine per bhi ho rahi hai






Hello,

Simple type .. put the script I'm giving you anywhere you want.

Like


vi /etc/squid/ip.sh

Or

vi /root/Desktop/ip.sh

Or

vi /blah/blah/ip.sh


Paste there some lines


#!/bin/bash
#echo 1 > /proc/sys/net/ipv4/ip_forward

iptables -F
iptables -t nat -F

iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT

iptables -t nat -A POSTROUTING -j MASQUERADE


Then

service iptables save

service iptables restart


Then nslookup cnn.com

It will show you this

nslookup cnn.com
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
Name: cnn.com
Address: 64.236.16.20
Name: cnn.com
Address: 64.236.16.52

---------------------


Then type


cat /etc/squid/squid.conf | sed '/ *#/d; /^ *$/d'

And paste all what it shows YOU.

------------------------

And how your *nix box is connected to Windows Box?

1) Try Cross Cable?
2) Through Switch?
3) Users are getting Bandwidth through *nix box?
3) Howmany NIC's you have on your Box? (NIC = Lan Card)


Thanks

..

Regards,

Khurram Nawaz.
+92-300-4141791
+92-42-5432259

cancerian_pisces@hotmail.com

thecooldude
Lance Naik
Posts: 43
Joined: Sun Nov 26, 2006 6:04 pm
Location: Dubai, UAE.
Contact:

RE-REPLY

Postby thecooldude » Mon Feb 19, 2007 1:14 am

SORRY

Type

vi /etc/squid/ip.sh
And paste the text below: -


#!/bin/bash
#echo 1 > /proc/sys/net/ipv4/ip_forward

iptables -F
iptables -t nat -F

iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT

iptables -t nat -A POSTROUTING -j MASQUERADE

Then type

chmod +x ip.sh

Then cd /etc/squid

Then ./ip.sh

Then service iptables save

And restart



Thanks

..

Regards,

Khurram Nawaz.
+92-300-4141791
+92-42-5432259

cancerian_pisces@hotmail.com

LinuxNerd
Lance Naik
Posts: 39
Joined: Wed Sep 15, 2004 1:45 am

Postby LinuxNerd » Mon Feb 19, 2007 1:50 am

Have you checked your route table entries?

LinuxFreaK
Site Admin
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
Location: Karachi
Contact:

Re:

Postby LinuxFreaK » Mon Feb 19, 2007 9:42 am

Dear Siraj Ahmed,
Salam,

If i am not wrong this person is doing Internet sharing using Windows 2000 Professional.

# iptables -t nat -F
# iptables -F
# netconfig --device=eth0


Configure your IP Address and in Gateway give IP Address of your Windows 2000 Professional Machine.

Best Regards.
Farrukh Ahmed

ranatanveer
Subedar
Posts: 355
Joined: Sat May 07, 2005 11:54 am
Location: Lahore
Contact:

Postby ranatanveer » Mon Feb 19, 2007 1:24 pm

I agree with linuxfreak
indeed it is a gateway problem
Regards

Rana Tanveer
+923224194457
Linux Student

For Affordable Web Development http://www.affordableprogrammers.com
http://www.qualityprogrammers.com


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 2 guests