YAHOO WITH NO PROXY

Discussion regarding the installation and configuration of Linux distributions.

YAHOO WITH NO PROXY

Postby Siraj Ahmed » Fri Mar 09, 2007 4:13 pm

Assalam o Aykum

sub doston aur khair khaon ko....

networking with 2 lan card internet from windows 2000 Prifessional
to linux EP 3
windows 2000
ip = 192.168.0.1
sn = 255.255.255.0

linux EP 3
eth0 = connected to windows 2000 Professional
ip = 192.168.0.2
sn = 255.255.255.0
gw = 192.168.0.1

eth1 = connected to client Pc
ip = 10.0.0.1
sn = 255.0.0.0
gw = 10.0.0.1

problem ye hai k client pc per browsing tou ho rahi hai magar Internet Explorer mai ip dalney k baad 10.0.0.1:8080 yahoo no proxy per connect nahi ho raha jes sey web cam aur voice chat mai problem ho rahi hai please any one help me JAZA KALLAH KHAIR..................
Siraj Ahmed
Lance Naik
 
Posts: 25
Joined: Thu Dec 08, 2005 10:22 pm
WLM: sscable@hotmail.com
Yahoo Messenger: sscable2002@yahoo.com
AOL: New+Karachi
Location: New Karachi

Postby zaigham_tt » Fri Mar 09, 2007 4:46 pm

i have already answered it previously....

msn messenger connect via IE'settings and yahoo connect directly that's why yahoo required proxy.

1st of all why r u doing networking with 2 lancards and using win2000 prof.

and which link u have been provided to ur clients. it's ISP or DSL or something else.
Last edited by zaigham_tt on Fri Mar 09, 2007 4:52 pm, edited 1 time in total.
zaigham_tt
Havaldaar
 
Posts: 142
Joined: Fri Sep 22, 2006 8:33 pm
Website: http://www.programming-world.4t.com

Re: YAHOO WITH NO PROXY

Postby abakali » Fri Mar 09, 2007 4:46 pm

Siraj Ahmed wrote:Assalam o Aykum

sub doston aur khair khaon ko....

networking with 2 lan card internet from windows 2000 Prifessional
to linux EP 3
windows 2000
ip = 192.168.0.1
sn = 255.255.255.0

linux EP 3
eth0 = connected to windows 2000 Professional
ip = 192.168.0.2
sn = 255.255.255.0
gw = 192.168.0.1

eth1 = connected to client Pc
ip = 10.0.0.1
sn = 255.0.0.0
gw = 10.0.0.1

problem ye hai k client pc per browsing tou ho rahi hai magar Internet Explorer mai ip dalney k baad 10.0.0.1:8080 yahoo no proxy per connect nahi ho raha jes sey web cam aur voice chat mai problem ho rahi hai please any one help me JAZA KALLAH KHAIR..................


AOA
are you enable IP forwarding of incoming packets

try out this

#!/bin/sh

# enable IP forwarding (of incoming packets)
echo 1 > /proc/sys/net/ipv4/ip_forward


# Select Values
IPTABLES=/sbin/iptables
EXTDEV="eth1"



# flush any old rules
$IPTABLES -F -t nat

# turn on NAT (IP masquerading for outgoing packets)
$IPTABLES -A POSTROUTING -t nat -o $EXTDEV -j MASQUERADE

# Redirect 80 port on Squid
$IPTABLES -t nat -A PREROUTING -s 10.0.0.0/24 -p tcp -m multiport --dports 80 -j REDIRECT --to-port 8080

save in /etc/rc.d/rc.local or file
then run /etc/rc.d/rc.local or file
Asif Bakali !
Feel free to contact me (flames about my english and the useless of this driver will be redirected to /dev/null, oh no, it's full...).
abakali
Naik
 
Posts: 91
Joined: Wed Jun 01, 2005 5:38 pm

Postby Siraj Ahmed » Fri Mar 09, 2007 9:16 pm

Assalam o Alykum Asif Bhai (Asif Baqali)

mai very new for linux aap thora detail mai aur urdu mai samjahengey k ye rules mujhe kaha per apply karney hai aur ye jo aap ney lekha hai nechey file ko save kaisey karna hai please..


save in /etc/rc.d/rc.local or file
then run /etc/rc.d/rc.local or file
Siraj Ahmed
Lance Naik
 
Posts: 25
Joined: Thu Dec 08, 2005 10:22 pm
WLM: sscable@hotmail.com
Yahoo Messenger: sscable2002@yahoo.com
AOL: New+Karachi
Location: New Karachi

Postby abakali » Sat Mar 10, 2007 2:16 am

Siraj Ahmed wrote:Assalam o Alykum Asif Bhai (Asif Baqali)

mai very new for linux aap thora detail mai aur urdu mai samjahengey k ye rules mujhe kaha per apply karney hai aur ye jo aap ney lekha hai nechey file ko save kaisey karna hai please..


save in /etc/rc.d/rc.local or file
then run /etc/rc.d/rc.local or file


AOA

fell free to call me

+92 (333) 2118477
Asif Bakali !

Feel free to contact me (flames about my english and the useless of this driver will be redirected to /dev/null, oh no, it's full...).
abakali
Naik
 
Posts: 91
Joined: Wed Jun 01, 2005 5:38 pm

Postby zaigham_tt » Sat Mar 10, 2007 12:57 pm

simply save this command by writing in
vi /etc/rc.local

or

type

echo "IPTABLES -A POSTROUTING -t nat -o eth0 -j MASQUERADE" >> /etc/rc.local
zaigham_tt
Havaldaar
 
Posts: 142
Joined: Fri Sep 22, 2006 8:33 pm
Website: http://www.programming-world.4t.com

Postby nomankhn » Sat Mar 10, 2007 4:54 pm

zaigham_tt wrote:simply save this command by writing in
vi /etc/rc.local

or

type

echo "IPTABLES -A POSTROUTING -t nat -o eth0 -j MASQUERADE" >> /etc/rc.local



Dear you are right but requires little bit change

You are right, but Capital IPTABLES will not work


[root@station7 ~]# cat >> /etc/rc.local

type this -> iptables -A POSTROUTING -t nat -o eth0 -j MASQUERADE

press enter one time after typing above command , and then press control+d.

verify your process

# [root@station7 ~]# cat /etc/rc.local
#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local

iptables -A POSTROUTING -t nat -o eth0 -j MASQUERADE



Regards
Noman Liaquat Khanzada Rajput
Linux means productivity and fun.
We all love Linux, but it's also a fact that some people might not be able to migrate.
nomankhn
Colonel
 
Posts: 714
Joined: Wed Aug 07, 2002 8:00 pm

Postby Siraj Ahmed » Sun Mar 11, 2007 7:20 am

Assalam o Alykum

sub doston ka shukriya jenhoney mere help ki lekin mai asal mai linux k liye very Anari ho mera problem abhi tak solve nahi howa browsing server per aur client per ho rahi hai explorer mai ip dalney k baad lekin mai chata ho without ip k browsing ho ( Transparent ) aur yahoo bhi connect ho raha hai lekin use proxy k sath mai chata ho no proxy per connect ho
Siraj Ahmed
Lance Naik
 
Posts: 25
Joined: Thu Dec 08, 2005 10:22 pm
WLM: sscable@hotmail.com
Yahoo Messenger: sscable2002@yahoo.com
AOL: New+Karachi
Location: New Karachi

Postby zaigham_tt » Sun Mar 11, 2007 3:26 pm

I got it.
First u Disable ur firewall and also de-active SELINUX. then cheack it. :wink:

when u give services to ur client from linux pc so u it is necessary to disable ur firewall and de-active SELINUX.
zaigham_tt
Havaldaar
 
Posts: 142
Joined: Fri Sep 22, 2006 8:33 pm
Website: http://www.programming-world.4t.com

Postby nomankhn » Mon Mar 12, 2007 11:23 am

Dear,

you have to configure transparent proxy, search in linux, i or some other persons wrote alot
about that, then you can resolve your issue, easily.

Regards
Noman Liaquat Khanzada Rajput
Linux means productivity and fun.
We all love Linux, but it's also a fact that some people might not be able to migrate.
nomankhn
Colonel
 
Posts: 714
Joined: Wed Aug 07, 2002 8:00 pm

Postby Siraj Ahmed » Fri Mar 23, 2007 9:44 pm

Assalam o Alykum dosto


mere masla jou ka tou hi hai
Siraj Ahmed
Lance Naik
 
Posts: 25
Joined: Thu Dec 08, 2005 10:22 pm
WLM: sscable@hotmail.com
Yahoo Messenger: sscable2002@yahoo.com
AOL: New+Karachi
Location: New Karachi


Return to “%s” Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron