Page 1 of 2

PTCL DSL PPPoe

Posted: Sun Jul 22, 2007 11:52 pm
by bachajamuraa
salamz.....
i have ptcl dsl...and use red hat enterprise linux... with transprate proxy..
i want connect dsl with my linux server... but i don't know how to config pppoe in linux... can any one help me ..step by step how to config pppoe in linux...

Posted: Sun Jul 22, 2007 11:57 pm
by Zaheer
Dont PTCL gave you a external DSL modem ?

Posted: Mon Jul 23, 2007 12:41 am
by bachajamuraa
yes.. i got dsl modem.... but .. it's connet only pppoe.. and i don't know how to config pppoe in linux...

Posted: Mon Jul 23, 2007 5:02 am
by asaddotcom
Sallamz,

Use PPP over Ethernet in DSL Modem "192.168.1.1" with user name and password, and direct connect DSL modem with your Linux.

For step by step configuration follow the instructions:

Web Login with your DSL modem write in internet explorer 192.168.1.1
give username and password "ZXDSL"
click on connection setting--->
delete all connection form there--->
click on "create a new connection"--->
chose "PPP over Ethernet"--->
click "goto next step"--->

Connection SETTING:-

vpi: 0
vcl: 103
Qos: UBR
ppp option:
Authentication: NONE
Username: 042-xxxxxxx
Password: 113xxxxxxxx
and finally click" create this new service"
after this click on Advance settings---->
then click on "security"---->
see the tag "Security Interfaces"
click on "add interface"
Name: ppp0
click on apply--->
click to "enable NAT to internal interfaces"

FINAL Proccess:

click on "Maintenance" left side menu
chose "Save" option and press the save button--->
again click on "Restart" and press restart button..

Note: don't check Reset to factory default settings!!!!

Now attach DSL modem with Linux--->ethernet and in /etc/resolv.conf
write:
nameserver 203.135.0.70
nameserver 203.135.1.117
save and exit

Enjoy!! PTCL Broadband Service

Best Regards:
Asad Ali (Network Admin)
DotCom Computers
Shop# B-4, Basement Regal Center, Regal Chowk, Hall Road Lahore
Tel: 042-7350810
Mob: 0321-9449320

Posted: Mon Jul 23, 2007 1:47 pm
by kbukhari
use adsl-setup at linux root shell

Posted: Mon Jul 23, 2007 4:40 pm
by bachajamuraa
asaddotcom thankz.. for help... but i use your steps.. it's not working...

Posted: Mon Jul 23, 2007 10:46 pm
by asaddotcom
bachajamuraa wrote:asaddotcom thankz.. for help... but i use your steps.. it's not working...


Sallam,

do u gave manual ip address to your linux box eth0 which is given by PTCL ? like 192.168.1.2 ???

Posted: Mon Jul 23, 2007 11:44 pm
by mudasir
Dear bachajamuraa,

Here is what i did to my PTCL DSL...it is working..

Step 1 .
goto http://192.168.1.1
uid = admin
pass = admin

goto Home menu.
then goto WAN Settings.

PVC Number = PVC-0
Wan Type = PPP
Connection Type = PPPoE
VPI/VCI = 0 / 103
Encap. = LLC
Default Route = Enabled

User Name = xxxxxxx
Password = xxxxxxx
Use DNS = Enabled
Max Idle Time = Always On

Save these settings and restart your modem

Then goto DNS Settings in Home menu

DNS Status = Enabled
Primary DNS Address 202.125.128.204
Secondary DNS Address 202.125.148.204

Save thses settings and restart your modem


Step 2.

Goto Advanced Menu.
then goto ADSL Settings.
Name = Value
ADSL Modulation = Multimode
EC/FDM Mode = EC
BitSwap = Enable

Save your settings and restart your modem

Step 3.

now set you LAN Card as follows

IP ADDRESSES = 192.168.1.2
SUBNET = 255.255.255.0
GATEWAY = 192.168.1.1

Prefered DNS Server = 202.125.128.204
Alternate DNS Server = 202.125.148.204

restart Network Services.

Now edit /etc/resolve.conf as follows
add these entries

nameserver 202.125.128.204
nameserver 202.125.148.204

Thats it...

Hope this works for you....

Posted: Tue Jul 24, 2007 10:44 am
by nomankhn
Dear,

How many network cards are required in that scenarios, i am talking about linux box

Whats ur suggestion about

eth0 192.168.1.1

eth1 192.168.2.1

Where Linux Machine is getting 202.x.x.x ip address.


How may DSL Providers are in Lahore and Karachi Support these types of settings.

Regards,
Noman Khanzada

Posted: Tue Jul 24, 2007 1:19 pm
by kbukhari
mudasir wrote:Dear bachajamuraa,

Here is what i did to my PTCL DSL...it is working..

Step 1 .
goto http://192.168.1.1
uid = admin
pass = admin

goto Home menu.
then goto WAN Settings.

PVC Number = PVC-0
Wan Type = PPP
Connection Type = PPPoE
VPI/VCI = 0 / 103
Encap. = LLC
Default Route = Enabled

User Name = xxxxxxx
Password = xxxxxxx
Use DNS = Enabled
Max Idle Time = Always On

Save these settings and restart your modem

Then goto DNS Settings in Home menu

DNS Status = Enabled
Primary DNS Address 202.125.128.204
Secondary DNS Address 202.125.148.204

Save thses settings and restart your modem


Step 2.

Goto Advanced Menu.
then goto ADSL Settings.
Name = Value
ADSL Modulation = Multimode
EC/FDM Mode = EC
BitSwap = Enable

Save your settings and restart your modem

Step 3.

now set you LAN Card as follows

IP ADDRESSES = 192.168.1.2
SUBNET = 255.255.255.0
GATEWAY = 192.168.1.1

Prefered DNS Server = 202.125.128.204
Alternate DNS Server = 202.125.148.204

restart Network Services.

Now edit /etc/resolve.conf as follows
add these entries

nameserver 202.125.128.204
nameserver 202.125.148.204

Thats it...

Hope this works for you....


mudassar did u try adsl-setup command in rhel ?

Posted: Tue Jul 24, 2007 3:31 pm
by mudasir
Dear kbukhari,

I have not tried adsl-setup command, the method i have mentioned above works for me. However their might some other settings in LAHORE, so you have to call 1236 for guidance.

Hey 1 more thing, i called 1236 and asked is their any different configuration on LINUX or not and the guy told me that they dont know anything regarding LINUX .. lol :D

I think one of senior guys from this website should try their they might get high pay... this is just a thought.

Posted: Tue Jul 24, 2007 4:20 pm
by lambda
you couldn't pay me enough to deal with people who can't google.

Posted: Tue Jul 24, 2007 5:11 pm
by mudasir
Dear Lambda,

I am not telling that i will pay the guy, i am saying that PTCL "might" hire at high PAY...

I hope you understand....

Posted: Tue Jul 24, 2007 5:16 pm
by lambda
you misread my comment. i meant the general "you", not you in particular.

Posted: Tue Jul 24, 2007 9:23 pm
by nomankhn
Hi Mudasir,

I am waiting for my answer.


regards,
Noman Khanzada