Page 1 of 1

64 bit distro

Posted: Mon Nov 12, 2007 2:14 pm
by ashariqbal
I have installed Mandriva x86_64 2007.1 and now I find that many things do not work. Many of the 64 bit libraries are not complete and sometimes the only solution is to run a 32 bit application.

Its actually ok on the server side, the problem I have is for desktop use.

Any one have better luck with other distros?

Posted: Mon Nov 12, 2007 3:27 pm
by lambda
i posted about my experience elsewhere, and i'll just copy and paste it here:

I run amd64 Ubuntu 7.10 (upgraded from 7.04) on an Athlon X2 3800+, and have been 64-bit since June or so. Problems so far:

* Most firefox plugins (adblock plus, greasemonkey, firebug, etc) work, but there is no native flash for 64-bit Linux. There is a workaround (a plugin hack that lets you use the normal 32-bit files from Adobe), but it doesn't seem to work as well with 7.10. I haven't investigated it in detail -- there could be a simple fix for this. (Unfortunately, most flash ads display just fine.)
* No sun java plugin for firefox. There are 32-bit and 64-bit JRE/JDKs for Java 5 and Java 6, but the 64-bit Java 6 packages don't seem to ship with a plugin for firefox.
* A few apps aren't 64-bit clean, like scheme48 or opendylan. There is a workaround for opendylan. I've seen some posts on the scheme48 list about building/running a 64-bit vm, but I don't know what its status is.
* No 64-bit Google Gears, Google Toolbar, or Google Desktop. I believe you can build Google Gears for amd64 systems by checking it out of svn and building it manually, but I haven't tried that. Google Toolbar installs, and appears to run, but there are a few odd errors in firefox's error console.

id games run fine -- I've had no trouble running Quake2, Quake 4, ET:QW, RTCW, etc. Second Life works without a hitch.

Firefox tends to allocate a lot more ram -- it's not unusual for me to have 600-800MB allocated (virt, not res). I have two gigs and a dualcore, but still.

Posted: Wed Nov 14, 2007 10:18 am
by ashariqbal
This is very surprising because I have been running mailservers on 64 bit for more than a year.

I just assumed that 64 bit desktop things would work just as well :D

Posted: Wed Nov 14, 2007 4:31 pm
by lambda
ashariqbal wrote: I just assumed that 64 bit desktop things would work just as well :D
you probably don't depend on commercial software on a server, like flash. also, the tools i mentioned that don't work properly (scheme48, opendylan) are not easy to convert to amd64 (they are either written on the assumption that they'll run on 32bit hardware, or they generate assembly directly, and need to be taught amd64 instructions).

Posted: Thu Dec 20, 2007 4:47 am
by shakeel_jee7

Dear All;

I have also AMD Athlon64 X2 4400+ with 320 GB SATAII with 16 MB Cache, 2 GB RAM and nVIDIA GeForce 8600 GTS 256 MB.
I am using Ubuntu 7.10 Gutsu Gibbon 64 bit edition, but its performance is very low, when starting. It takes about 3+ minutes for starting it, and also and I choose Ubuntu from Boot Loader for starting, the Display suddenly goes off and come after the processing of 3 or minutes.

Can any one tell me, why it is performing very slow, instead of such a high End Hardware???

Also to tell you that I am using all the desktop Effects on and working fine and also using Compiz Fusion of Customized Desktop Effects.