Page 1 of 1

Cant install VMWare server on FC8

Posted: Mon Jul 21, 2008 2:01 am
by CyberFreak
Hi previously on my FC6 i successfully install VMWare server but when i updated my system (ok reinstall FC8) then i have a problem to intall VMware server
when i run vmware-any-update ./
installation abot here
make[1]: Entering directory `/usr/src/kernels/′
CC [M] /tmp/vmware-config8/vmmon-only/linux/driver.o
CC [M] /tmp/vmware-config8/vmmon-only/linux/driverLog.o
CC [M] /tmp/vmware-config8/vmmon-only/linux/hostif.o
CC [M] /tmp/vmware-config8/vmmon-only/common/comport.o
CC [M] /tmp/vmware-config8/vmmon-only/common/cpuid.o
In file included from include/asm/bitops.h:2,
from /tmp/vmware-config8/vmmon-only/./include/vcpuset.h:74,
from /tmp/vmware-config8/vmmon-only/./include/modulecall.h:23,
from /tmp/vmware-config8/vmmon-only/common/vmx86.h:19,
from /tmp/vmware-config8/vmmon-only/common/hostif.h:18,
from /tmp/vmware-config8/vmmon-only/common/cpuid.c:15:
include/asm/bitops_32.h:9:2: error: #error only can be included directly
make[2]: *** [/tmp/vmware-config8/vmmon-only/common/cpuid.o] Error 1
make[1]: *** [_module_/tmp/vmware-config8/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/kernels/′
make: *** [vmmon.ko] Error 2
make: Leaving directory `/tmp/vmware-config8/vmmon-only’
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at “” and

Execution aborted.
know i dont know what to do ?

Posted: Mon Jul 21, 2008 3:10 am
by fawad
The VMWare any-to-any patch (unofficial, of course) is known to fix a lot of such build problems on Linux. Try it out here.

Posted: Mon Jul 21, 2008 8:47 pm
by CyberFreak
problem is solved on my fc6 i have any update 111 patch when i installed new 115 problem is solved