Page 1 of 1

Subversion Installation Using Yum

Posted: Sun Aug 17, 2008 8:17 pm
by myfoot
Hello,
Am trying to install subversion Using Yum. And got this errors which are given below.Please help me out in this regard.

Thanks.
=====================================

yum install subversion mod_dav_svn
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package mod_dav_svn.i386 0:1.5.1-0.1.el5.rf set to be updated
---> Package subversion.i386 0:1.5.1-0.1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_dav_svn
--> Processing Dependency: libapr-1.so.0 for package: subversion
--> Processing Dependency: rtld(GNU_HASH) for package: subversion
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: subversion
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mod_dav_svn
--> Processing Dependency: libcrypto.so.6 for package: subversion
--> Processing Dependency: libssl.so.6 for package: subversion
--> Processing Dependency: libaprutil-1.so.0 for package: subversion
--> Processing Dependency: python(abi) = 2.4 for package: subversion
--> Processing Dependency: rtld(GNU_HASH) for package: mod_dav_svn
--> Processing Dependency: libdb-4.3.so for package: subversion
--> Processing Dependency: liblber-2.3.so.0 for package: subversion
--> Processing Dependency: libneon.so.25 for package: subversion
--> Processing Dependency: libldap-2.3.so.0 for package: subversion
--> Finished Dependency Resolution
Error: Missing Dependency: httpd-mmn = 20051115 is needed by package mod_dav_svn
Error: Missing Dependency: libapr-1.so.0 is needed by package subversion
Error: Missing Dependency: rtld(GNU_HASH) is needed by package subversion
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package subversion
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package mod_dav_svn
Error: Missing Dependency: libcrypto.so.6 is needed by package subversion
Error: Missing Dependency: libssl.so.6 is needed by package subversion
Error: Missing Dependency: libaprutil-1.so.0 is needed by package subversion
Error: Missing Dependency: python(abi) = 2.4 is needed by package subversion
Error: Missing Dependency: rtld(GNU_HASH) is needed by package mod_dav_svn
Error: Missing Dependency: libdb-4.3.so is needed by package subversion
Error: Missing Dependency: liblber-2.3.so.0 is needed by package subversion
Error: Missing Dependency: libneon.so.25 is needed by package subversion
Error: Missing Dependency: libldap-2.3.so.0 is needed by package subversion
========================================

Re:

Posted: Mon Aug 18, 2008 7:57 am
by LinuxFreaK
Dear myfoot,
Salam,

Use below command.

# yum -y install subversion

Best Regards.

Yaseen

Posted: Wed Oct 08, 2008 7:23 am
by ghulam yaseen
Dear Farrukh bhai;

I am getting this error even after your recommended command
=================
Error: Missing Dependency: httpd-mmn = 20051115 is needed by package mod_dav_svn
=================
Please advise

LinuxFreaK wrote:Dear myfoot,
Salam,

Use below command.

# yum -y install subversion

Best Regards.

Re: Yaseen

Posted: Wed Oct 08, 2008 8:40 am
by LinuxFreaK
Dear ghulam yaseen,
Salam,

ghulam yaseen wrote:I am getting this error even after your recommended command
=================
Error: Missing Dependency: httpd-mmn = 20051115 is needed by package mod_dav_svn
=================


Which Linux Distribution you are using ?

Best Regards.

Posted: Wed Oct 08, 2008 9:18 am
by osama

Yaseen

Posted: Thu Oct 09, 2008 5:15 am
by ghulam yaseen
Dear Farrukh bhai :) ,

I am using Fedora Core release 5 (Bordeaux).
this is how it makes to be some problem
===============
yum install subversion mod_dav_svn
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core [1/3]
extras [2/3]
updates [3/3]
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package mod_dav_svn.i386 0:1.3.2-2.1 set to be updated
--> Running transaction check
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_dav_svn
--> Finished Dependency Resolution
Error: Missing Dependency: httpd-mmn = 20051115 is needed by package mod_dav_svn
==============
i have also yum -t subversion mod_dav_svn, if i am not wrong then i am missing some apache module with that or some thing other. please suggest

LinuxFreaK wrote:Dear ghulam yaseen,
Salam,

ghulam yaseen wrote:I am getting this error even after your recommended command
=================
Error: Missing Dependency: httpd-mmn = 20051115 is needed by package mod_dav_svn
=================


Which Linux Distribution you are using ?

Best Regards.
:roll:

Posted: Thu Oct 09, 2008 3:07 pm
by osama
Use this

yum install subversion
yum install mod_dav_svn