checking for X... configure: error

Discussion regarding the installation and configuration of Linux distributions.

Postby outstream » Sat Oct 25, 2003 3:23 pm

AoA

mr Faraz.Fazil sir

yeah i was wrong...that was ldconfig...it worked but ./configure is still giving the same error. i tried reading that config.log but i couldnt understand what was written in it. there was a long list of system variables and at the end it just did exit (0);

aab kia karein?

Thanks for ur precious time

Good Day
Testing?What's that? If it compiles, its good, if it boots up it is perfect.
----------------------------------------------------
Imran
Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby Faraz.Fazil » Sat Oct 25, 2003 11:30 pm

Since the QT 3 rpm got installed successfully, ideally, the program should have worked and that error shoudl have gone.But now that, it is still giving the error, download and install QT from the latest official sources (newer than that rpm):

ftp://ftp.trolltech.com/qt/source/qt-x1 ... 2.2.tar.gz

After u install qt from the sources, try that error giving compile again
Linux for Life!
Faraz.Fazil
Major General
 
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
WLM: faraz7476@hotmail.com
Location: Karachi/Pakistan/Earth/Universe

Postby outstream » Wed Nov 05, 2003 5:12 am

AoA

mr Faraz.Fazil sir

sir jii this took really long time. Actually during installation of that qt from source, it took so much time after 'make' command. i waited for it to end for like one hour and still it didnt finish. I left it on and went to sleep :P . When i woke up tow i came to know that power went off while i was sleeping and my computer was turned off abruptly bcuz of that. on booting again it started giving me errors during boot process, so i installed the whole thing again. the whole Linux. ok now again i started installing qt from source and it took about 2 hours and 15 mins in whole process :P , and the tragic part is its again giving the same error :cry: . but this time there is one new line in error that it is giving. i think i should show u the output, that will give u better idea of what i m saying:

=================================

checking for libpng... no
checking for libjpeg6b... no
checking for libjpeg... no
configure: WARNING: libjpeg not found. disable JPEG support.
checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

=================================

Make sure that you have compiled Qt with thread support!

this is a new line. I didnt see this line in error messages before. and as far as i remember, it didnt give me any option to compile qt with thread support during whole process.

Thanks for ur precious time

Good Day
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby Faraz.Fazil » Wed Nov 05, 2003 5:58 am

YOu know what?

Many linux users have had problems and errors Compiling QT from the sources and they have also encountered QT errors when compiling certain programs from sources (Just like in your case).So you are not alone hehe.

Many users have reported similar errors in the past.

Now, do this:

Issue these commands when compling qt from the sources:

1.make distclean

2.

./configure --thread --with-qt-dir=/usr/local/qt/ --with-qt-includes=/usr/local/qt/include/ --with-qt-librries=/usr/local/lib/

The above config will also include thread support.

then run the make commands as usual.

It should work.

If the above does not work, then it may be a problem due to some config problem with gcc.In that case you may need to use these commands:

gcc -v
g++ -v

first and then recompile QT from the sources again (using the commands given before in the earlier part of this post.)
Linux for Life!
Faraz.Fazil
Major General
 
Posts: 1024
Joined: Thu Jul 04, 2002 5:31 pm
WLM: faraz7476@hotmail.com
Location: Karachi/Pakistan/Earth/Universe


Return to “%s” Installation

Who is online

Users browsing this forum: No registered users and 2 guests