Page 1 of 1

Worldcall Evdo USB on Linux

Posted: Sat Jul 04, 2009 9:06 pm
by pesheek
I am using Worldcall Evdo usb on FC10.

When first you insert the Worldcall Evdo USB device which is AnyDATA Corporation device appears as a USB CDROM/MMC.
( lsusb output )

Code: Select all

Bus 007 Device 004: ID 05c6:1000 Qualcomm, Inc.


When the device is inserted, my "/dev/cdrom" link is changed from

Code: Select all

lrwxrwxrwx 1 root root 3 2009-07-04 21:42 /dev/cdrom -> sr0

TO

Code: Select all

lrwxrwxrwx 1 root root 3 2009-07-04 16:44 /dev/cdrom -> sr1


The modem will not appear until this "CD/MMC" is "Ejected"
I use simple "eject" to do the job by issuing one or two times

Code: Select all

[root@localhost ~]# eject /dev/cdrom
[root@localhost ~]# eject /dev/cdrom


Now the Standard USB Modem will appear
( lsusb output )

Code: Select all

Bus 007 Device 003: ID 16d5:6502 AnyDATA Corporation



By using kppp or any dialup software of your choice you can connect to internet.

Code: Select all

Modem Device : /dev/ttyUSB0
UserName     : wcall@worldcall.com
Password     : wcall
Phone No     : #777
DNS          : 203.81.204.2
               203.81.204.23


I use kppp and face two issues
1) Default Gateway is not set and
2) No DNS Servers Entry in /etc/resolv.conf

For DNS Server, make the entry in /etc/resolv.conf file like

Code: Select all

nameserver 203.81.204.2
nameserver 203.81.204.23


and Default Gateway is a little tricky :)

Code: Select all

ppp0      Link encap:Point-to-Point Protocol
          inet addr:115.186.67.233  P-t-P:192.168.2.10  Mask:255.255.255.255


your local address of the ppp0 is the default gateway which I set with "route" command

Code: Select all

[root@localhost ~]# route add default gw 115.186.xxx.xxx


So every time you connect you have to set the default gateway.

Happy Netting.

For device mode switch the following can be done
( I didnt tested any of the follwoing )

USB_ModeSwitch - Activating Switchable USB Devices on Linux
http://www.draisberghof.de/usb_modeswitch/

Or using "udev". Making a rule entry in /etc/udev/rules.d/ to automatically eject the device when inserted.

Code: Select all

ENV{ID_CDROM}=="?*",ENV{ID_SERIAL}=="XXXXXXXXXXX-99999999999-0:0",RUN+="/usr/bin/eject /dev/%k"


Please let me know any script or tools to resolve the USB Mode switch and Default Gateway issues.

Eject & Default Gateway Scripts for kppp

Posted: Sun Jul 05, 2009 5:57 pm
by pesheek
Just write two bash scripts and make their entry in kppp configuration.

Eject CROM/MMC
/root/ejectCDROM.sh

Code: Select all

#!/bin/sh
eject /dev/sr1
eject /dev/sr1


Set Default Gateway on Connect
/root/setdfGWppp0.sh

#!/bin/sh
route add default gw $(ifconfig | grep 115.186 | cut -d : --fields=2 | cut -d P --fields=1)


And make entry in kppp
Account -> Execute -> Before Connect : /root/ejectCDROM.sh
Account -> Execute ->Upon Connect : /root/setdfGWppp0.sh

Still looking for better script or solution.

Posted: Sun Jul 05, 2009 11:25 pm
by lambda
i use pppd directly instead of using frontends like kppp. do you have "defaultroute" in /etc/ppp/options?

Posted: Tue Jul 07, 2009 1:09 pm
by pesheek
i use pppd directly instead of using frontends like kppp. do you have "defaultroute" in /etc/ppp/options?

Once I used a script for dialup in SLackware 2.0. If you can send me sample pppd dialing code/script, I will check what can I do or you can use the following code at the end of your script to set default gateway.

Code: Select all

route add default gw $(ifconfig | grep 115.186 | cut -d : --fields=2 | cut -d P --fields=1)


And Please check the IP range ( 115.186.x.x) I use in Karachi and you are in Lahore.

Posted: Tue Jul 07, 2009 1:36 pm
by lambda
just put defaultroute in /etc/ppp/options. if kppp is a frontend for pppd, it'll use it automatically.

you can always use "ps auxww" to see what kppp runs in the background, if anything.

CentOS 5.1

Posted: Sat Jul 18, 2009 3:59 pm
by pesheek
Hi,

I just installed CentOS 5.1 and do the following to get usb modem

Code: Select all

[root@localhost ~]# eject /dev/scd0
[root@localhost ~]# modprobe usbserial vendor=0x16d5 product=0x6502


:)

PTCL EVDO

Posted: Thu Sep 03, 2009 7:27 pm
by muzaffar
I am using PTCL EVDO should i follow the same procedure for PTCL device as well


Regards
Muzaffar Abbas
CCNA JNCIA JNCIS
92312-4400442

Posted: Fri Dec 18, 2009 11:34 pm
by alimuzaffarkhan
After a long and hard research on Mr. Google I was able to solve the problem. Took me 3 or so days to nail it but finally did it. I use WorldCalls EVDO in Lahore on Huawei USB modem. If anyones interested you can go to the following link:
http://tux-n00b.blogspot.com/2009/05/huawei-ec168c-on-ubuntu-804-hardy-heron.html

Caution: Use
wcall@worldcall.com as username
wcall as password
and #777 as phone no.

If anyone is interested I could clean the details up for Karmic and post in a separate post. (just pm me enough pms and I will clean it up meaning make is easier to follow)

Posted: Mon Jan 11, 2010 9:56 am
by DivineLight
Yar ye HUAWEI USB device which is given these days. LC186C, that is not working with NM on Ubuntu 9.10 right?

I am trying my luck with wvdial or maybe ppp now. will update soon.

Posted: Sat Feb 13, 2010 8:41 pm
by saquib_javed
any idea how to do it under ununtu 9.10

i tried myself but it didnt worked

the device is not detected or m looking at wrong thing