smtp problem in Sendmail

Taking care of your Linux box.

smtp problem in Sendmail

Postby kashif » Sun Dec 21, 2003 12:25 am

Asslam 0 alikum!
Dear friends I made Redhat 7.2 mail server.

when i send and recieve mail from server it works fine.

But when i connect for client(outlook express) Mail recieves properly

but i am unable to sendmail from clients.
it give following eror message.





The connection to the server has failed. Account: 'Sendmail', Server:

'192.168.0.1', Protocol: SMTP, Port: 25, Secure(SSL): No, Socket Error:

10061, Error Number: 0x800CCC0E






More over when I try to telnet server from client at port 25(SMTP)
it does not telnet the sever.

Allah Hafiz
kashif
Naib Subedar
 
Posts: 305
Joined: Wed Oct 15, 2003 2:44 am
Location: Okara

Postby zaeemarshad » Sun Dec 21, 2003 12:36 am

this problem is caused by a line in your sendmail.mc that tells the sendmail server to listen only on the local host for smtp. i dont exactly remember that line but you will find this one as it contains 127.0.0.1 in it and probably localhost too if i remember correctly. Simply delete it or add dnl before it and then remake your sendmail.cf and this will work fine. better search the forum as i posted this somewhere else too.

Regards
Zaeem Arshad
zaeemarshad
Lieutenant Colonel
 
Posts: 660
Joined: Sat Jul 06, 2002 12:35 pm
Website: http://zaeem.no-ip.org
WLM: zarshadvirk@hotmail.com
Yahoo Messenger: negativecreep61@yahoo.com
AOL: zarshadvirk
Location: Islamabad

Postby kernel-trap » Thu Dec 25, 2003 2:53 pm

Yes he is right

aslo dont forget to put yr clients ip range in /etc/mail/access

and after that

makemap hash /etc/mai/access < /etc/mail/access
kernel-trap
Havaldaar
 
Posts: 105
Joined: Thu Dec 25, 2003 2:31 pm

problem with two sendmail Servers

Postby kashif » Thu Dec 25, 2003 7:55 pm

Asslam 0 alaikum

Sir Thanks all for giving me vauluable informations.

Now sir new problem arise.

I have configured one mail server properly.
and getting and sending mail from client computers properly.

Now I have configured TWO sendmail server.

Now when I send mail from clinet of one mail server(tahir.com) to the client of other mail server(ali.com) it does not recieve .
/var/log/maillog gives the following info





[root@Redhat root]# cat /var/log/maillog |grep queued
Dec 25 18:53:10 Redhat sendmail[1186]: hBPNqU501186: to=info@ali.com, delay=00:00:40, mailer=esmtp, pri=33, dsn=4.4.3, stat=queued



Please help me
Allah Hafiz
kashif
Naib Subedar
 
Posts: 305
Joined: Wed Oct 15, 2003 2:44 am
Location: Okara

Re:

Postby LinuxFreaK » Fri Dec 26, 2003 8:32 am

Dear Tahir,
Salam,

I think you must read the Sendmail FAQ also Check out Server Resources

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Postby zaeemarshad » Fri Dec 26, 2003 11:42 pm

have u configured dns for both domains. the dns server should be same or atleast both servers should know of the multiple dns servers if u have any. check ur access file for blocks.

regards
zaeem
zaeemarshad
Lieutenant Colonel
 
Posts: 660
Joined: Sat Jul 06, 2002 12:35 pm
Website: http://zaeem.no-ip.org
WLM: zarshadvirk@hotmail.com
Yahoo Messenger: negativecreep61@yahoo.com
AOL: zarshadvirk
Location: Islamabad

Postby kernel-trap » Sat Dec 27, 2003 11:12 am

Yes check your both machines dns entries . aslo verify there have route to access each other

are you facing problem when only that domain our all domain try send and receiving mail from hotmail etc

is there any error message you got when u try to send mail .

Regards

KT
kernel-trap
Havaldaar
 
Posts: 105
Joined: Thu Dec 25, 2003 2:31 pm


Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 1 guest