Lan Router problem

Taking care of your Linux box.

Lan Router problem

Postby zaeemarshad » Wed Jan 07, 2004 11:17 pm

ok ppl now i have got a serious problem and i am in dire need of help. ok here is the scenario.

Linux server running on smoothwall express 2.0 rc1. about 30 win{9x/me/xp/2k} clients behind it. initially all the clients were in the same subnet that is 192.168.0.0 netmask 255.255.255.0 . But in that scenario users could change ip and atleast browse the local lan. [they were blocked from using net if the mac address and the ip didnt match.] any way there are three routes for em now.

route add -net 192.168.0.0 255.255.255.0 dev eth0 being the vital one for net access. two other for the isp's server.

now we have changed the subnet mask to 255.255.255.254 effectively moving each client in his own subnet. they can communicate with the router by using the default routes(previous settings) but obviously cannot access each other. i added a route for a netmask for 255.255.255.254 but it didnt seem to help. the clients cannot ping each other. their gateway though is set to that of linux. i want em to be atleast able to ping each other and see each other in the network neighbourhood. any solutions??

one more thing that ip_forward is set to 1. so ipforwarding is definitely enabled.

Mind you that subnetting was done to avoid direct access to lan pcs via switch and every packet is made to pass through the router. i hope u understand. i need help on it. waiting.....

Regards
Zaeem
zaeemarshad
Lieutenant Colonel
 
Posts: 660
Joined: Sat Jul 06, 2002 12:35 pm
Website: http://zaeem.no-ip.org
WLM: zarshadvirk@hotmail.com
Yahoo Messenger: negativecreep61@yahoo.com
AOL: zarshadvirk
Location: Islamabad

Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 2 guests

cron