Mounting drives problem

Taking care of your Linux box.

Mounting drives problem

Postby DumbDuffer » Fri Jan 30, 2004 5:21 am

AOA,
i just wanted to ask that
1) how can i made all my fat partitions get mounted at startup/boot.
i know that it can be done while installing linux, but , i forgot to do it during recent installation.
The only clue i have is that i may need to edit fstab.
But i am completely cluless, how to do this.
2)How can i access/mount my ntfs partition in linux.
i heared from a friend of mine that recently a very good driver is made available ,that can mount ntfs with read/write
access in linux.
3)I don't have read/write access on my fat partitions
i usually mount them using
mount -t vfat /dev/hdax /home/username/directorypath
i get only read access ,
whats wrong with ma linux box.
if possible , plz reply in detail.
Your help is anticipated.
Regards.
DumbDuffer
Cadet
 
Posts: 4
Joined: Fri Jan 30, 2004 2:48 am

Re:

Postby LinuxFreaK » Fri Jan 30, 2004 7:45 am

Dear DumbDuffer,
Salam,

Sir, You can mount your FAT32 Partision Automatically at Boot time by making changes to /etc/fstab file. Edit your fstab file

# vi /etc/fstab

#
# /etc/fstab
#
# <device> <mountpoint> <filesystemtype><options> <dump> <fsckorder>

/dev/hdb5 / ext2 defaults 1 1
/dev/hdb2 /home ext2 defaults 1 2
/dev/hdc /mnt/cdrom iso9660 noauto,ro,user 0 0
/dev/hda1 /mnt/dos/c vfat defaults 0 0
/dev/hdb1 /mnt/dos/d vfat defaults 0 0
/dev/fd0 /mnt/floppy ext2 noauto,user 0 0
/dev/hdb4 none ignore defaults 0 0

none /proc proc defaults
/dev/hdb3 none swap sw

make sure that you have enable rw access to your mount point or may be some kinda permission problem :) NTFS Read Write Support Has been done by Kernel 2.6.x :)

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Postby we » Fri Jan 30, 2004 3:37 pm

Assalam-O-Alaikum

ntfs readonly access

http://linux-ntfs.sourceforge.net//rpm/index.html

Ejaz Khalid Farooqui
Regards
EKF
+971 50 7861136
we
Lance Naik
 
Posts: 43
Joined: Wed Jan 21, 2004 6:36 pm
ICQ: 32164473
WLM: ekfarooqui@msn.com
Yahoo Messenger: ekfarooqui@yahoo.com
Location: Dubai, UAE

Re:

Postby LinuxFreaK » Fri Jan 30, 2004 11:48 pm

Dear DumbDuffer,
Salam,

Captive: The first free NTFS read/write filesystem for GNU/Linux

This project introduces the first free access in read/write to the discs under NTFS. It is possible to assemble your partition ms Windows NT, 200x or XP like volume accessible by GNU/Linux

Remote loading in form tar.gz or rpm:

http://www.jankratochvil.net/project/captive/#download

Project implements the first full read/write free access drives to NTFS disk. You edge mount your Microsoft Windows NT, 200x gold XP partition have has transparently accessible volume for your GNU/Linux.

This compatibility was achieved in the Wine way by using the original Microsoft Windows ntfs.sys driver. It emulates the required subsystems of the Microsoft Windows kernel by reusing one of the original ntoskrnl.exe, ReactOS shares, gold this project' S own reimplementations, one has box by box basis. Project includes the first open source Ms-Windows kernel API for Free operating systems. Involvement of the original driver files was chosen to achieve the best and unprecedented filesystem compatibility and safety.

Have opposed to other projects this is currently the only software supporting the full read/write access including the possibility to create/delete files, modify directories etc.

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Postby DumbDuffer » Sat Jan 31, 2004 2:32 am

ok, now here i am
i have succed mounting my fat partitions automaticaly on boot.
i entered these line in my fstab
/dev/hda6 /home/directory path vfat default 0 0
/dev/hda7 /home/directory path vfat default 0 0
every thing seems fine except :shock: i don't have write access to both of these partitions, any suggestion?
And i am also downloading the rpm for ntfs, i hope it will work .
now, how can i get write rights on these partitions.
some one told me to enter
/dev/hda7 /home/directory path vfat rw,exec,umask=000 0 0
instead of
/dev/hda7 /home/directory path vfat default 0 0
so , what is the difference ?and which one i should use.
DumbDuffer
Cadet
 
Posts: 4
Joined: Fri Jan 30, 2004 2:48 am

Re:

Postby LinuxFreaK » Sat Jan 31, 2004 2:43 am

Dear DumbDuffer,
Salam,

/dev/hda7 /home/directory path vfat rw,exec,umask=000 0 0


Yes, Its right or make sure that you have enable write access on fat partision in your kernel :) BTW whats your Kernel Version ?

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Postby zaeemarshad » Sat Jan 31, 2004 7:09 pm

isnt it defaults in the fstab line or default. as far as i remeber it is defaults and both mandrake and slack on my system show defaults. check if this is the cause of the problem.

Regards
Zaeem
zaeemarshad
Lieutenant Colonel
 
Posts: 660
Joined: Sat Jul 06, 2002 12:35 pm
Website: http://zaeem.no-ip.org
WLM: zarshadvirk@hotmail.com
Yahoo Messenger: negativecreep61@yahoo.com
AOL: zarshadvirk
Location: Islamabad


Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 1 guest

cron