masquerading is not working

Taking care of your Linux box.

masquerading is not working

Postby kashif » Tue Feb 24, 2004 2:42 pm

Asslam 0 alikum!
I am facing much problem in masquerding .
I have search the entire forum and i think i did all the configration well but it is not working ... i did the follow
my redhat is 7.2

my /etc/firewall file is as

/

Code: Select all

sbin/iptables -F
/sbin/iptables -t nat -A POSTROUTING -o ppp0 -s 0/0 -d 0/0 -j MASQUERADE
/sbin/iptables -t filter -A FORWARD -i eth0  -j ACCEPT



aslo given

echo 1 > /proc/sys/net/ipv4/ip_forward



and at client computer i using that server as gatway

also loacded the module by
modprobe iptable_nat


After making configration i aslo do
/etc/firewall to implement
I connect net throught modem
and at server browsing is being well.
no problem at server


and lsmod commnad shows the module
But masquerding is not working please him me
Kashif
**********************************************

As-Salaatu was-Salaamu Alaika Ya Sayyidi Ya Rasool ALLAH

**********************************************
kashif
Naib Subedar
 
Posts: 305
Joined: Wed Oct 15, 2003 2:44 am
Location: Okara

Re:

Postby LinuxFreaK » Thu Feb 26, 2004 10:18 pm

Dear kashif,
Salam,

If you read this thread then i think you will get the answer :)

http://www.linuxpakistan.net/forum2x/vi ... php?t=1208

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi


Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 1 guest

cron