any body worked in Fedora

Taking care of your Linux box.

any body worked in Fedora

Postby shahzad » Mon Mar 15, 2004 10:15 am

salam!


My previous about iptables, and the syntax you gave me aint working on fedora, shows a message, command not found. I even checked the path, but of no use. Well, i m using shorewall firewall now, and thats good. But my problem is that, that i have setup dns, apache server on my system, as i did on RH7.2 RH 8.0 and RH9.0, but still not working, i even set the path for the db files in /etc/named.conf, but still not working. there is a directory /var/named/chroot/var/named/ and i also worked there to my dns start working, but all in vain... any clue, hint????
There is no glory without sufferings...
shahzad
Lance Naik
 
Posts: 19
Joined: Wed Mar 03, 2004 6:10 pm
Website: http://comradblues.spymac.net
WLM: asm4c@hotmail.com
Yahoo Messenger: shezibhai@yahoo.com
Location: Pakistan

Postby zaeemarshad » Mon Mar 15, 2004 7:16 pm

any error messages you would like to give. comeon be descriptive. cant shoot like that??? btw which dns server are you using and r u using Fedora or what???

Regards
-Zaeem
zaeemarshad
Lieutenant Colonel
 
Posts: 660
Joined: Sat Jul 06, 2002 12:35 pm
Website: http://zaeem.no-ip.org
WLM: zarshadvirk@hotmail.com
Yahoo Messenger: negativecreep61@yahoo.com
AOL: zarshadvirk
Location: Islamabad

thanks for replying

Postby shahzad » Tue Mar 16, 2004 11:04 pm

Actually when i setup the dns server and set the parameters, and even when i start the named daemon, it doesnt give me error, but when i nslookup for my host or dig them, they aint give me any answer. :>
There is no glory without sufferings...
shahzad
Lance Naik
 
Posts: 19
Joined: Wed Mar 03, 2004 6:10 pm
Website: http://comradblues.spymac.net
WLM: asm4c@hotmail.com
Yahoo Messenger: shezibhai@yahoo.com
Location: Pakistan

Re: thanks for replying

Postby lambda » Wed Mar 17, 2004 2:10 am

turn on query logging. stick this into the options section of your named.conf:

Code: Select all

  logging {
    channel q { file "/var/log/named/q"; print-time yes; severity info; };
    category queries { q; };
  };


you might have to mess with it a bit; i copied it out of a bind8 config file i set up years ago.

if the problem is with remote queries, use tcpdump.

Code: Select all

tcpdump -n -p -i eth0 port 53


(replace eth0 with your external interface)

see if you get replies to your dns queries. you probably won't.

check your firewall rules carefully, make sure they allow incoming dns replies. if it's stateful, all the better.

you'd do well to figure out what your iptables problem is.
Watch out for the Manners Taliban!
Isn't it amazing how so many people can type "linuxpakistan.net" into their browsers but not "google.com"?
lambda
Major General
 
Posts: 3452
Joined: Tue May 27, 2003 7:04 pm
Website: http://www.hungry.com/~fn/
Location: Lahore


Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 2 guests

cron