managing users and sound server problem

Taking care of your Linux box.

managing users and sound server problem

Postby outstream » Wed Apr 14, 2004 10:05 pm

AoA

I am using slackware 9.1

I am facing a little problem in managing users. :oops: I made another user 'abc', but my box wouldnt let this user to mount the fat drives. after doing su , i mount the fat drive and transferred required data from fat drive to /home/abc/fatdrive. then after exiting su account and comming back as 'abc' user when i tried to access /home/abc/fatdrive, it again said permission denied.

i looked for any bash commands who can let me assign some super privilidges to 'abc' but couldnt found one. also in KUser i couldnt find anything as giving privilidges to user. so then using KUser, i edited the 'abc' account and put it into group of "root". but it still wouldnt let me access the fatdrive or allow me to issue mount command.

another thing related to same login/privilidges is, on start up it asks me to configure sound server for user. in slackware installation i read to issue command alsaconf, which`ll setup sound server. that worked with "root" but when i login using 'abc' account, it again says could not found sound server or something like that. being log ined as 'abc' it also wouldnt let me issue command of alsaconf and doing su setsup the sound server but after doing relogin it again doesnt works :oops:

can any body suggest any solution to these two problems?
Testing?What's that? If it compiles, its good, if it boots up it is perfect.
----------------------------------------------------
Imran
Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby barlas » Thu Apr 15, 2004 12:28 am

Asalaam-u-Alikum!

I think you can use 'sudo' command for this purpose, first of all you may need to edit /etc/sudoers to list the name of users you want to give the sudo privilidge..

btw why don't you edit /etc/fstab for mounting file system at startup...

Regards
Barlas
Aqeel Zafar
barlas
Naib Subedar
 
Posts: 315
Joined: Mon Jun 30, 2003 11:07 am
Website: http://aqeeliz.com
Location: Lahore, Pakistan

Postby outstream » Thu Apr 15, 2004 2:30 am

AoA

barlas wrote:I think you can use 'sudo' command for this purpose, first of all you may need to edit /etc/sudoers to list the name of users you want to give the sudo privilidge


Thanks, how do i edit /etc/sudoers? i mean what contents should i put in, in order to give the privilidges.

barlas wrote:btw why don't you edit /etc/fstab for mounting file system at startup...


yeah that can be a way, but i dont think it would allow me to edit /etc/fstab without having root privilidges. and using root account the entries for auto mount r already set up in /etc/fstab, it was part of installation process.
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby farhantoqeer » Thu Apr 15, 2004 9:16 am

This is not the good practice, i meaa leting other then root mounting drives etc etc, though you can do that by setting the owner id bit of mount/umount/smbmount/ by using chmod u+s.
A: Yes
Q: Is top-posting bad?
farhantoqeer
Major General
 
Posts: 917
Joined: Thu Jun 27, 2002 5:45 pm
Website: http://www.emergen.biz
Location: Karachi

Postby outstream » Thu Apr 15, 2004 12:39 pm

AoA

yeah i agree its not good idea to let other users do the administrative jobs but i was just trying to check if it works then how it works :P .

Another thing is, I thought root can do anything, but apparently it seems its not setting the changes made by root for other users.

for example the home folder for 'abc' is /home/abc.
now i did su and became root.
i mounted the fat drive and copyied the file 123.bmp into /home/abc folder using 'root' account. /home/abc/123.bmp
now after exiting and comming back with user 'abc' when i checked /home/abc, the file 123.bmp that i copied was not there.
cant 'root' change settings and make it permanent for 'abc'?
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby farhantoqeer » Thu Apr 15, 2004 2:43 pm

before exiting from super user mode set appropriate file permissions for user.
A: Yes

Q: Is top-posting bad?
farhantoqeer
Major General
 
Posts: 917
Joined: Thu Jun 27, 2002 5:45 pm
Website: http://www.emergen.biz
Location: Karachi

Postby outstream » Thu Apr 15, 2004 8:46 pm

AoA

alright cool, so i found an article on net about editing /etc/fstab, as suggested by barlas as well.

here are the details

/etc/fstab before editing

Code: Select all

/dev/hdc8        swap             swap        defaults         0   0
/dev/hdc7        /                ext2        defaults         1   1
/dev/hdc9        /usr             ext2        defaults         1   2
/dev/hdc10       /opt             ext2        defaults         1   2
/dev/hdc11       /home            ext2        defaults         1   2
/dev/hdc1        /fat-c           vfat        defaults         1   0
/dev/hdc5        /fat-d           vfat        defaults         1   0
/dev/hdc6        /fat-e           vfat        defaults         1   0
/dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0


/etc/fstab after editing

Code: Select all

/dev/hdc8        swap             swap        defaults         0   0
/dev/hdc7        /                ext2        defaults         1   1
/dev/hdc9        /usr             ext2        defaults         1   2
/dev/hdc10       /opt             ext2        defaults         1   2
/dev/hdc11       /home            ext2        defaults         1   2
/dev/hdc1        /fat-c           vfat        defaults,users         1   0
/dev/hdc5        /fat-d           vfat        defaults,users         1   0
/dev/hdc6        /fat-e           vfat        defaults,users         1   0
/dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0


note the changes made in lines /dev/hdc1, /dev/hdc5 & /dev/hdc6. the word 'users' has been put there with defaults.
it was supposed to allow all users in group 'users', to mount these vfat drives. but..................................

Code: Select all

imran@darkstar:~$ mount -t vfat /dev/hdc5 /home/imran/ddrive
mount: only root can do that
imran@darkstar:~$
:cry:

any ideas?
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad

Postby barlas » Thu Apr 15, 2004 10:10 pm

Salaam!

I have this line in my /etc/fstab

Code: Select all

/dev/hda1 /mnt/win vfat uid=0,gid=0,umask=022,noexec,quiet 0 0

and when I boot I already have win partion mounted (read only)

Barlas
Aqeel Zafar
barlas
Naib Subedar
 
Posts: 315
Joined: Mon Jun 30, 2003 11:07 am
Website: http://aqeeliz.com
Location: Lahore, Pakistan

Postby outstream » Thu Apr 15, 2004 10:25 pm

AoA

if you erase noexec from that, will it allow r/w access?
Testing?What's that? If it compiles, its good, if it boots up it is perfect.

----------------------------------------------------

Imran

Registered Linux User # 334322
outstream
Naib Subedar
 
Posts: 322
Joined: Wed Sep 24, 2003 10:04 pm
Location: islamabad


Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 1 guest

cron