Sendmail Configuration

Taking care of your Linux box.

Sendmail Configuration

Postby mustafamotiwala » Sun May 25, 2003 12:18 pm

Hello all,
Now this is a really strange problem that has consumed me to my limit. I have multiple domains, and one mail server for them. The dns MX record correctly reflects this one server (serverX) as the mail server for all domains.(Domains X, Y,S & T). I have created the virtusertable file, and configured sendmail to use this file. Created mailboxes for all such users of domains X Y S & T. Now the trouble is everytime i try to send a mail to domain Y S T or for that matter any other domain, it says the domain lookup failed. I tried issuing a simple dig command from the server and the domain lookups are working fine. After a lot of head banging - I configured the domaintable file to reflect domain X Y & T for testing. Then i tried sending a test mail, this time it accepted the "MAIL FROM" for these domains, but on 'RCPT TO" it simply gave an error "User unknown". Can anyone tell me what I am doing wrong? In the previous setup for these domains - the domaintable feature isnt even enabled in the sendmail.mc - yet it works fine. I am at my hairs end with this thing.
Regards,
Mustafa Motiwala. :x
mustafamotiwala
Cadet
 
Posts: 3
Joined: Tue May 06, 2003 2:09 pm
WLM: mustafamotiwala@hotmail.com
Yahoo Messenger: th3_assassin@yahoo.com
AOL: facade0@netscape.com
Location: Karachi, Pakistan.

Re: Sendmail Configuration

Postby LinuxFreaK » Tue May 27, 2003 12:47 am

Dear Mustafa Motiwala,
I prefer you to read this page. http://www.sendmail.org/virtual-hosting.html
Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi


Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 2 guests

cron