MSN not working

Taking care of your Linux box.

MSN not working

Postby janali » Mon Oct 06, 2008 11:10 am

Dear All,

My network is
(1)dansguardian
(2) Trenmicro
(3)Squid proxy

problem is that MSN is not working kindly help me in this Thanks
janali
Naik
 
Posts: 58
Joined: Tue Jul 17, 2007 1:34 pm

Postby x2oxen » Tue Oct 07, 2008 9:05 am

Would you like to tell how you have configured your squid proxy??
Muhammad Usman
+92-321-6640501
Chemonics International
http://usmanpk.com
x2oxen
Major General
 
Posts: 1114
Joined: Wed Aug 22, 2007 3:17 pm
Website: http://usmanpk.com
WLM: x2oxen@hotmail.com
Yahoo Messenger: x2oxen
Location: Faisalabad

Postby janali » Tue Oct 07, 2008 9:41 am

very simple not any thing new just default settings etc

http_port 3122
acl all src 0.0.0.0/0.0.0.0
acl abc src 192.168.1.0/255.255.255.0
janali
Naik
 
Posts: 58
Joined: Tue Jul 17, 2007 1:34 pm

Postby x2oxen » Tue Oct 07, 2008 9:56 am

And what ip tables rules you using?? and have your enable ip forwarding & natting
Muhammad Usman

+92-321-6640501

Chemonics International

http://usmanpk.com
x2oxen
Major General
 
Posts: 1114
Joined: Wed Aug 22, 2007 3:17 pm
Website: http://usmanpk.com
WLM: x2oxen@hotmail.com
Yahoo Messenger: x2oxen
Location: Faisalabad

Postby janali » Tue Oct 07, 2008 11:42 am

No enable ip forwarding & natting
one thing i noted that when in proxy settings i give port of Trendmicro its working fine and than give port of squid also working fine but when i give dansguardian port the problem start.
Trendmicro port 3128
Squid port 3122
Dansguardian port 8080
janali
Naik
 
Posts: 58
Joined: Tue Jul 17, 2007 1:34 pm

Re:

Postby LinuxFreaK » Wed Oct 08, 2008 8:32 am

Dear janali,
Salam,

MSN have nothing to do with your proxy. However if you have restrict access to MSN using Squid. You need to use IP Masquerading (NAT) using iptables.

FYI, http://www.netfilter.org/documentation/ ... WTO-4.html

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Postby janali » Wed Oct 08, 2008 9:14 am

how to use? if you help me in this thanks
janali
Naik
 
Posts: 58
Joined: Tue Jul 17, 2007 1:34 pm

Postby x2oxen » Wed Oct 08, 2008 9:25 am

Just apply the iptables rules to MASQUERADE the traffic on your outgoing interface and you can redirect your port 80 traffic on your squid port using iptables.
Muhammad Usman

+92-321-6640501

Chemonics International

http://usmanpk.com
x2oxen
Major General
 
Posts: 1114
Joined: Wed Aug 22, 2007 3:17 pm
Website: http://usmanpk.com
WLM: x2oxen@hotmail.com
Yahoo Messenger: x2oxen
Location: Faisalabad

Postby janali » Wed Oct 08, 2008 10:12 am

I just wanted 1st user hit on port 8080 wich is Dansguardian's port, 8080 port forword to 3128 port wich is Trendmicro port, 3128 port forword to 3122 port wich is Squid port. These all things on my single pc 192.168.1.10 .
janali
Naik
 
Posts: 58
Joined: Tue Jul 17, 2007 1:34 pm

Postby janali » Fri Oct 10, 2008 8:51 am

I'm not sure what of the above has caused this, but it may be DansGuardian. It listens on the port the proxy used to (8080), and redirects requests through the cache, which listens only on port 3128 on the same machine as dansguardian. I have played around with some acl rules trying to get squid to allow msn for only certain hosts, but I dont seem to be having any luck. I suspect that it may be that MSN is getting caught in DansGuardian somewhere and not being passed through to the proxy. Help me plzzz
janali
Naik
 
Posts: 58
Joined: Tue Jul 17, 2007 1:34 pm

Postby x2oxen » Fri Oct 10, 2008 10:12 am

You still not enabled ip forwarding and natting right??
Muhammad Usman

+92-321-6640501

Chemonics International

http://usmanpk.com
x2oxen
Major General
 
Posts: 1114
Joined: Wed Aug 22, 2007 3:17 pm
Website: http://usmanpk.com
WLM: x2oxen@hotmail.com
Yahoo Messenger: x2oxen
Location: Faisalabad

Postby janali » Fri Oct 10, 2008 10:59 am

guide me plz I am new in Linux.
janali
Naik
 
Posts: 58
Joined: Tue Jul 17, 2007 1:34 pm

Postby x2oxen » Fri Oct 10, 2008 5:31 pm

Code: Select all

echo "1" > /proc/sys/net/ipv4/ip_forward


This will turn on ip forwarding

Code: Select all

iptables –t nat –A POSTROUTING –o eht1 –j MASQUERADE


This will do Masquerading.. I considered eth1 is your external interface. you can change it if its different in your scenario.
Muhammad Usman

+92-321-6640501

Chemonics International

http://usmanpk.com
x2oxen
Major General
 
Posts: 1114
Joined: Wed Aug 22, 2007 3:17 pm
Website: http://usmanpk.com
WLM: x2oxen@hotmail.com
Yahoo Messenger: x2oxen
Location: Faisalabad

Postby LinuxFreaK » Mon Oct 13, 2008 9:24 am

Dear janali,
Salam,

x2oxen wrote:

Code: Select all

echo "1" > /proc/sys/net/ipv4/ip_forward


This will turn on ip forwarding

Code: Select all

iptables –t nat –A POSTROUTING –o eht1 –j MASQUERADE


# iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Postby janali » Mon Oct 13, 2008 1:42 pm

Dear All,
Thanks a lot problem is solved with your kind help.
janali
Naik
 
Posts: 58
Joined: Tue Jul 17, 2007 1:34 pm


Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 1 guest

cron