Trasparent Proxy don't work after recompiling squid from src

General discussion about PLUC and Linux in Pakistan.

Trasparent Proxy don't work after recompiling squid from src

Postby amirza » Wed Jun 06, 2007 12:09 pm

I have confirured my SQUID 2.6 STABLE 13 with these options
./configure --enable-storeio="diskd,aufs,ufs"
--enable-removal-policies="lru,heap"
--enable-delay-pools
--enable-snmp
--enable-arp-acl
--enable-cache-digests
--enable-linux-netfilter
--disable-ident-lookups
--enable-underscores
--enable-auth="basic"
--enable-basic-auth-helpers="NCSA"
--with-maxfd=8192
--enable-default-err-language="English"
--enable-err-languages="English"
Now it is working and when i enable the transparent mode it give me errors while starting the squid.
httpd_accel_port 80
httpd_accel_host virtual
httpd_accel_with_proxy on
httpd_accel_uses_host_header on
The error shows these 4 lines. As I have compiled with "--enable-linux-netfilter", it should work as Transparent.
Please Help

Atif Anwar Mirza
atif.mirza@gmail.com
amirza
Cadet
 
Posts: 3
Joined: Fri Oct 14, 2005 6:01 pm

Postby zaigham_tt » Wed Jun 06, 2007 12:41 pm

Dear amirza,
Edit This line
[b]http_port 172.16.200.250:3128 transparent[/b]

Instead of this:

[b]httpd_accel_port 80
httpd_accel_host virtual
httpd_accel_with_proxy on
httpd_accel_uses_host_header on [/b]
zaigham_tt
Havaldaar
 
Posts: 142
Joined: Fri Sep 22, 2006 8:33 pm
Website: http://www.programming-world.4t.com

Postby zaigham_tt » Wed Jun 06, 2007 12:43 pm

Dear amirza,
Edit This line
[u]http_port 172.16.200.250:3128 transparent[/u]

Instead of this:

[u]httpd_accel_port 80
httpd_accel_host virtual
httpd_accel_with_proxy on
httpd_accel_uses_host_header on [/u]

And then Apply Iptable Rule:
[u]iptables -t nat -A PREROUTING -i ppp0 -p tcp --dport 80 -j REDIRECT --to-port 3128[/u]
zaigham_tt
Havaldaar
 
Posts: 142
Joined: Fri Sep 22, 2006 8:33 pm
Website: http://www.programming-world.4t.com


Return to “%s” General

Who is online

Users browsing this forum: No registered users and 0 guests

cron