Kernel Compilation

Protecting your Linux box
Kamranalilakhnavi
Lance Naik
Posts: 25
Joined: Thu Mar 31, 2005 2:26 am

Kernel Compilation

Postby Kamranalilakhnavi » Wed Jan 09, 2008 2:22 am

Hello Everyone,
I am compiling kernel with grsecurity pacth on RedHat4 Enterprise. Every thing went fine but I am not able to boot my system with new kernel , getting the following error.

Warning: unable to open an initial console.

System hanged after this warning.
Any help would be highly appreciated..


"
Regards,
Pasha

LinuxFreaK
Site Admin
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
Location: Karachi
Contact:

Re: Kernel Compilation

Postby LinuxFreaK » Thu Jan 10, 2008 1:55 pm

Dear Kamranalilakhnavi,
Salam,

Kamranalilakhnavi wrote:I am compiling kernel with grsecurity pacth on RedHat4 Enterprise. Every thing went fine but I am not able to boot my system with new kernel , getting the following error.

Warning: unable to open an initial console.

System hanged after this warning.
Any help would be highly appreciated.."


Have you selected support for Unix pty support and under file system have you selected devpts ?

Best Regards.
Farrukh Ahmed

Kamranalilakhnavi
Lance Naik
Posts: 25
Joined: Thu Mar 31, 2005 2:26 am

Postby Kamranalilakhnavi » Sat Jan 19, 2008 2:54 am

Hello,
I am compiling it from old kernel config.
Regards,

Pasha

Kamranalilakhnavi
Lance Naik
Posts: 25
Joined: Thu Mar 31, 2005 2:26 am

Postby Kamranalilakhnavi » Sat Jan 19, 2008 6:49 am

I didn't choose any new option.
Regards,

Pasha

LinuxFreaK
Site Admin
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
Location: Karachi
Contact:

Re:

Postby LinuxFreaK » Sat Jan 19, 2008 9:34 am

Dear Kamranalilakhnavi,
Salam,

Please post output of following command.

# cd /usr/src/linux
# grep "CONFIG_UNIX98_PTYS" config


Best Regards.
Farrukh Ahmed

nomankhn
Colonel
Posts: 714
Joined: Wed Aug 07, 2002 8:00 pm

Postby nomankhn » Sun Jan 20, 2008 1:44 am

Hi Sir,

Pls check do you have all headers and their code is avaialble with that distribution and by the way what update you are using and what specific version you are using for security software.

If you are still getting that error, contact your vendor or its better to install following software but still you need source-code to compile it from source code. lets try it from www.kernel.org

following softwares are required for kernel that comes with RedHat Advance server update #2.

kernel-devel-2.6.9-22.EL
kernel-smp-devel-2.6.9-22.EL
kernel-doc-2.6.9-22.EL
kernel-2.6.9-22.EL
kernel-hugemem-devel-2.6.9-22.EL
kernel-utils-2.4-13.1.69

you pls check your side.

cd /usr/src/kernel/*EL-i686

My suggestion is that you should recompile your security software with that kernel version sourc-code that it prefers.

Regards,
Noman Liaquat

LinuxFreaK
Site Admin
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
Location: Karachi
Contact:

Postby LinuxFreaK » Sun Jan 20, 2008 11:19 am

Dear nomankhn,
Salam,

nomankhn wrote:Pls check do you have all headers and their code is avaialble with that distribution and by the way what update you are using and what specific version you are using for security software.

If you are still getting that error, contact your vendor or its better to install following software but still you need source-code to compile it from source code. lets try it from www.kernel.org

following softwares are required for kernel that comes with RedHat Advance server update #2.

kernel-devel-2.6.9-22.EL
kernel-smp-devel-2.6.9-22.EL
kernel-doc-2.6.9-22.EL
kernel-2.6.9-22.EL
kernel-hugemem-devel-2.6.9-22.EL
kernel-utils-2.4-13.1.69

you pls check your side.

cd /usr/src/kernel/*EL-i686

My suggestion is that you should recompile your security software with that kernel version sourc-code that it prefers.


I believe he is trying to re-compile kernel so it does not need any kernel headers. As he is compiling from source.

Best Regards.
Farrukh Ahmed

nomankhn
Colonel
Posts: 714
Joined: Wed Aug 07, 2002 8:00 pm

Postby nomankhn » Sun Jan 20, 2008 12:24 pm

Year Mr.Farrukh,

I know that what he asked for and I observe this thing number of times on RHEL thats why i am asking w.r.t to that headers, it will not start if some files are not there in.

/usr/include/

its impossible then.

Regards,
Noman Liaquat

nomankhn
Colonel
Posts: 714
Joined: Wed Aug 07, 2002 8:00 pm

Postby nomankhn » Mon Jan 21, 2008 8:09 pm

Hi Kamranalilakhnavi,

Could you pls tell me about your RedHat Relase and kernel version.

Regards,
Noman Liaquat

LinuxFreaK
Site Admin
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
Location: Karachi
Contact:

Re:

Postby LinuxFreaK » Tue Jan 22, 2008 8:44 am

Dear nomankhn,
Salam,

Okay, This thread is dedicated to you :)

Best Regards.
Farrukh Ahmed

Kamranalilakhnavi
Lance Naik
Posts: 25
Joined: Thu Mar 31, 2005 2:26 am

Postby Kamranalilakhnavi » Tue Jan 29, 2008 12:44 am

Hello,
Kernel Version: 2.6.9-5.EL
Redhat: RHEL4


I have the following directories in
[root@station3 src]# pwd
/usr/src
[root@station3 src]# ls
kernels redhat
[root@station3 src]#
/usr/src/linux
Regards,

Pasha

nomankhn
Colonel
Posts: 714
Joined: Wed Aug 07, 2002 8:00 pm

Postby nomankhn » Mon Feb 04, 2008 11:18 pm

Right,

now download the kernel from www.kernel.org and start its compilation.

Download this kernel and start compiling then

http://www.kernel.org/pub/linux/kernel/ ... .14.tar.gz

Regards,
Noman Liaquat

Kamranalilakhnavi
Lance Naik
Posts: 25
Joined: Thu Mar 31, 2005 2:26 am

Postby Kamranalilakhnavi » Tue Feb 05, 2008 2:35 am

Thanks NoMan and Farrukh for your help.
Regards,

Pasha


Return to “Security”

Who is online

Users browsing this forum: No registered users and 0 guests