Cant install VMWare server on FC8

Discussion regarding the installation and configuration of Linux distributions.

Cant install VMWare server on FC8

Postby CyberFreak » Mon Jul 21, 2008 2:01 am

Hi previously on my FC6 i successfully install VMWare server but when i updated my system (ok reinstall FC8) then i have a problem to intall VMware server
when i run vmware-any-update ./runme.pl
installation abot here
make[1]: Entering directory `/usr/src/kernels/2.6.24.5-85.fc8-i686′
CC [M] /tmp/vmware-config8/vmmon-only/linux/driver.o
CC [M] /tmp/vmware-config8/vmmon-only/linux/driverLog.o
CC [M] /tmp/vmware-config8/vmmon-only/linux/hostif.o
CC [M] /tmp/vmware-config8/vmmon-only/common/comport.o
CC [M] /tmp/vmware-config8/vmmon-only/common/cpuid.o
In file included from include/asm/bitops.h:2,
from /tmp/vmware-config8/vmmon-only/./include/vcpuset.h:74,
from /tmp/vmware-config8/vmmon-only/./include/modulecall.h:23,
from /tmp/vmware-config8/vmmon-only/common/vmx86.h:19,
from /tmp/vmware-config8/vmmon-only/common/hostif.h:18,
from /tmp/vmware-config8/vmmon-only/common/cpuid.c:15:
include/asm/bitops_32.h:9:2: error: #error only can be included directly
make[2]: *** [/tmp/vmware-config8/vmmon-only/common/cpuid.o] Error 1
make[1]: *** [_module_/tmp/vmware-config8/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.23.1-42.fc8-i686′
make: *** [vmmon.ko] Error 2
make: Leaving directory `/tmp/vmware-config8/vmmon-only’
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at “http://www.vmware.com/download/modules/modules.html” and
“http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html”.

Execution aborted.
know i dont know what to do ?
CyberFreak
Havaldaar
 
Posts: 116
Joined: Mon Aug 01, 2005 12:20 am
Yahoo Messenger: tariq8862000@yahoo.com
Location: Karachi

Postby fawad » Mon Jul 21, 2008 3:10 am

The VMWare any-to-any patch (unofficial, of course) is known to fix a lot of such build problems on Linux. Try it out here.
fawad
Site Admin
 
Posts: 918
Joined: Wed Aug 07, 2002 8:00 pm
ICQ: 17672437
Website: http://www.fawad.net
WLM: fawadhalim@hotmail.com
Yahoo Messenger: fawad2048
AOL: fawadhalim
Location: Addison, IL

Postby CyberFreak » Mon Jul 21, 2008 8:47 pm

problem is solved on my fc6 i have any update 111 patch when i installed new 115 problem is solved
CyberFreak
Havaldaar
 
Posts: 116
Joined: Mon Aug 01, 2005 12:20 am
Yahoo Messenger: tariq8862000@yahoo.com
Location: Karachi


Return to “%s” Installation

Who is online

Users browsing this forum: No registered users and 2 guests

cron