grub issue

Discussion regarding the installation and configuration of Linux distributions.
ghulam yaseen
Naik
Posts: 68
Joined: Thu Aug 07, 2008 6:09 pm
Location: karachi

grub issue

Postby ghulam yaseen » Wed Oct 08, 2008 5:52 am

Hello :) ,

After i recompiled the kernel version today and rebooted the server, it did not reboot and then i tried with linux rescue mode. i executed this command /mnt/sysimage/sbin/grub-install /dev/hd0
grub not found
i get the above error. Please let me know how to fix this issue. :roll:

LinuxFreaK
Site Admin
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
Location: Karachi
Contact:

Re: grub issue

Postby LinuxFreaK » Wed Oct 08, 2008 8:39 am

Dear ghulam yaseen,
Salam,

ghulam yaseen wrote:After i recompiled the kernel version today and rebooted the server, it did not reboot and then i tried with linux rescue mode. i executed this command /mnt/sysimage/sbin/grub-install /dev/hd0
grub not found
i get the above error. Please let me know how to fix this issue. :roll:


You need to chroot into your /mnt/sysimage before running /sbin/grub-install /dev/hd0

$ chroot /mnt/sysimage
$ /sbin/grub-install /dev/hd0


Best Regards.
Farrukh Ahmed

x2oxen
Major General
Posts: 1114
Joined: Wed Aug 22, 2007 3:17 pm
Location: Faisalabad
Contact:

Postby x2oxen » Wed Oct 08, 2008 9:27 am

and you also need to tell the path where to install using -f flag (not sure) as in ubuntu when i recovered mine i had to tell that.
Muhammad Usman
+92-321-6640501
Chemonics International
http://usmanpk.com

Muhammad Saad
Battalion Havaldaar Major
Posts: 273
Joined: Sat Jan 27, 2007 11:07 pm
Location: Dera Ismail Khan, Pakistan
Contact:

Postby Muhammad Saad » Thu Oct 09, 2008 10:39 pm

I think it should be either hd0 or /dev/hda because I have never seen /dev/hd0 anywhere.

LinuxFreaK
Site Admin
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
Location: Karachi
Contact:

Re:

Postby LinuxFreaK » Mon Oct 13, 2008 9:34 am

Dear Muhammad Saad,
Salam,

Muhammad Saad wrote:I think it should be either hd0 or /dev/hda because I have never seen /dev/hd0 anywhere.


indeed.

Best Regards.
Farrukh Ahmed


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 0 guests