cache problem?

Taking care of your Linux box.

cache problem?

Postby smk08 » Tue Apr 21, 2009 7:57 am

Asslamu Alaikum

dear friends i am using wateen internet connection on my squid 2.6. it works well for all urls except the following links.
google.com yahoo.com and hotmail.com. when i tires to open these links the page is automatically redirected to refil.wateen.net. except these mentioned sites all other web sites opens properly.
but when i tries these links on the same wateen connection without proxy then these works well.
i have clear my squid cache and rotate its logs but the problem still exists.

pleeeeeeeese help to get rid of this problem.

Jazaaku Mullah.
Shahid Mahmood
0321-4538113
i am crazy to learn linux
smk08
Naik
 
Posts: 56
Joined: Fri Aug 08, 2008 1:44 pm
Location: Sheikhupura, Pakistan

Re:

Postby LinuxFreaK » Tue Apr 21, 2009 8:22 am

Dear smk08,
Salam,

May be your account is about to expire and you are getting this notice.

Best Regards.
Farrukh Ahmed
LinuxFreaK
Site Admin
 
Posts: 5132
Joined: Fri May 02, 2003 10:24 am
ICQ: 82075802
Website: http://www.linuxpakistan.net/wiki/index.php?pagename=LinuxFreak
WLM: f4fahmed@hotmail.com
Yahoo Messenger: f4fahmed@yahoo.com
AOL: linuxpakistan@aol.com
Location: Karachi

Postby smk08 » Tue Apr 21, 2009 9:22 am

Asslamu Alaikum


no dear friend thats not the problem because without using proxy( direct connection to wateen) all the websites open properly. But when i configure my browser to use the proxy then only pages like google.com yahoo.com and hotmail.com are redirected to refil.wateen.net. except these all websites work well behind proxy.

please guide me how resolve this issue.

Jazaak Mullah.
Shahid Mahmood

0321-4538113

i am crazy to learn linux
smk08
Naik
 
Posts: 56
Joined: Fri Aug 08, 2008 1:44 pm
Location: Sheikhupura, Pakistan

Postby x2oxen » Tue Apr 21, 2009 10:49 am

you sure you did not turn on offline mode? and yes check by adding these urls to no_cache acl and tell the result.
Muhammad Usman
+92-321-6640501
Chemonics International
http://usmanpk.com
x2oxen
Major General
 
Posts: 1114
Joined: Wed Aug 22, 2007 3:17 pm
Website: http://usmanpk.com
WLM: x2oxen@hotmail.com
Yahoo Messenger: x2oxen
Location: Faisalabad

Postby smk08 » Tue Apr 21, 2009 1:06 pm

Asslamu Alaikum

Dear friend i use the following acl to check the problem.

acl abc url_regex -i google.com yahoo.com hotmail.com

no_cache deny abc

i also carefully place these at the right place but same problem still exist.

dear friend i don't know how to turn on/off offline files. kindly also guide me how to do this.

Jazaak Mulllah.
Shahid Mahmood

0321-4538113

i am crazy to learn linux
smk08
Naik
 
Posts: 56
Joined: Fri Aug 08, 2008 1:44 pm
Location: Sheikhupura, Pakistan

Postby lambda » Tue Apr 21, 2009 3:54 pm

i assume your proxy system also does nat. install dsniff on your proxy system, and then type

Code: Select all

urlsnarf -n -i eth1
(where eth1 is your outside interface). try going to google's website both with and without the proxy set in the browser and see what you get.
Watch out for the Manners Taliban!
Isn't it amazing how so many people can type "linuxpakistan.net" into their browsers but not "google.com"?
lambda
Major General
 
Posts: 3452
Joined: Tue May 27, 2003 7:04 pm
Website: http://www.hungry.com/~fn/
Location: Lahore


Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 3 guests

cron