Centos server giving I/O Error

Taking care of your Linux box.

Centos server giving I/O Error

Postby mashkoor.qadir » Thu Jun 05, 2014 11:46 am

Hi guys,
My CentOS 5.4 server is running since 2009 working fine since yesterday. it suddenly stop responding. its very critical server for the company. I saw repeated following line and was unable to stop that.

/etc/rc.d/rc.sysinit: line 947: /bin/usleep: Input/Output error
This line just repeats over and over and I cant stop it with control-c it.
when i reboot the machine it failed mount local partitions and stuck. one more time i rebooted the message on the screen was,


setting host name xyz
setting up logical volume mangment:
/1: superblock has an invalid ext3 journal (inode 8)
clear
*** ext3 journal has been deleted - file system in ext2 only ***
Error reading block 2056 (attempt to read block from filesystem resulted in short read). Remounting root file system in
read-write mode. ok
Mounting local filesystems Failed
Enabling local filesystem quotas: Failed
Enabling /etc/fstab swaps: Failed

and hang at this stage. Again i rebooted this time server started and loaded most of the process at login stage it gave following messages.
end_request: I/O error, dev sdb, sector 247392428
EXT3-fs error (device sda3): ext3_find_entry: reading directory 528278814 offset 0

end_request: I/O error, dev sdb, sector 247392428
EXT3-fs error (device sda3): ext3_find_entry: reading directory 528278814 offset 0

end_request: I/O error, dev sdb, sector 247392428
EXT3-fs error (device sda3): ext3_find_entry: reading directory 528278814 offset 0

end_request: I/O error, dev sdb, sector 71
end_request: I/O error, dev sdb, sector 63
end_request: I/O error, dev sdb, sector 17414208
end_request: I/O error, dev sdb, sector 17414440
end_request: I/O error, dev sdb, sector 1028160
end_request: I/O error, dev sdb, sector 1028168
end_request: I/O error, dev sdb, sector 1028160
end_request: I/O error, dev sdb, sector 625137212
end_request: I/O error, dev sdb, sector 625137324
end_request: I/O error, dev sdb, sector 17414460
end_request: I/O error, dev sdb, sector 17414468
end_request: I/O error, dev sdb, sector 17414460
INIT: Id "x" respawaning toofast: disabled for 5 mints

I attached this DISK to an other running system and try to run the fsck command i was unable to run, the following error popups.
e2fsck: Attempt to read block from filesystem resulted in short read while to open /dev/sdb
Could this be a zero-length partition

where as fdisk -l displays only one drive.(its own drive)
and i am also unable to mount the Drive. when saw the disk with GUI interface with Disk management utility the disk shows unknown partition types.
I have googled this and gotten all sorts of ideas. Evey thing from bad RAM to bad DISK to config problems. But no changes were made.
How it could be fixed. Please help.
mashkoor.qadir
Lance Naik
 
Posts: 32
Joined: Mon Dec 20, 2010 10:27 pm
Yahoo Messenger: mashkoor.qadir@yahoo.com
Location: Karachi

Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 1 guest

cron