Squid acct as a Gateway

General discussion about Linux, Linux distribution, using Linux etc.
Post Reply
manwerjalil
Lance Naik
Posts: 28
Joined: Wed Apr 30, 2008 10:44 am
Location: Karachi
Contact:

Squid acct as a Gateway

Post by manwerjalil »

Dear all,

I am using squid on redhat linux 5 and now my organization asked to me stop configuring proxy option in internet explorer and provide internet access using gateway as we are using squid IP address as an gateway

anyone can help me how to do this?


Thanks
zmunawar
Cadet
Posts: 7
Joined: Fri Jun 20, 2008 6:15 pm

Post by zmunawar »

As i understand, you may need to operate transparent proxy.In that case you just have to point ur computer GW towards squid, and there is no need to give IP Address of Proxy server in ur explorer. Is this wht u want ?

Which squid version are you using ?
manwerjalil
Lance Naik
Posts: 28
Joined: Wed Apr 30, 2008 10:44 am
Location: Karachi
Contact:

Post by manwerjalil »

I am using Redhat linux entp 5 and squid-2.6.STABLE6-3.el5

I just configured squid like this

http_port 8080
acl our_network src 0/0
http_access allow our_network

i can access internet when i configure proxy option in internet explorer but can't access using gateway of squid IP on client machine

another problem is that i can't access IMAP SSL port 993 as i have mentioned in squid like

acl SSL_ports port 993
acl Safe_ports port 993

but its not working

my LAN is eth1 and INET is eth0

is there any good solution for this

Thanks
x2oxen
Major General
Posts: 1114
Joined: Wed Aug 22, 2007 3:17 pm
Location: Faisalabad
Contact:

Post by x2oxen »

configure it transparent and implement iptables rules which will be redirecting your port 80 traffic towards your squid port and enable natting.

this has been discussed in various posts before.

FYI http://usmanpk.com/index.php?option=com ... &Itemid=41
Muhammad Usman
+92-321-6640501
Chemonics International
http://usmanpk.com
manwerjalil
Lance Naik
Posts: 28
Joined: Wed Apr 30, 2008 10:44 am
Location: Karachi
Contact:

Post by manwerjalil »

I resolved the issue dear.
Post Reply